Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop that has Windows 7 64-bit as the main OS. I originally installed Ubuntu 10.10 using Wubi so I could have Windows and Linux to choose from at boot up. All worked great up until yesterday when I tried to install Ubuntu 11.04 using Wubi.

Now after the install when I rebooted the Windows boot manager has the option to choose Windows or Ubuntu, when I choose Ubuntu this is what it says:

Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:
 1. Insert your windows installation disc and restart your computer. 
 2. Choose your language settings, and then click "Next". 
 3. Click "Repair your computer "
If you don't have this disc, contact your system administrator it computer manufacturer for assistance. 

 File: \ubuntu\winboot\wubildr.mbr
 Status: 0xc000000e
 Info: The selected entry could not be loaded because the application is missing or corrupt.

I can boot into Windows just fine from the bootloader menu. I tried to uninstall Wubi, deleted the files associated with Wubi, then tried to do a side by side install of Ubuntu 11.04 using a downloaded ISO from Ubuntu's website. I burned it to a disc and booted the CD and did the install that way.

Still I got the same error screen as listed above.

Any ideas as to how I can fix GRUB or add GRUB to my boot up menu so I can boot into Ubuntu 11.04?

share|improve this question

2 Answers 2

My "Answer" to this problem ended up being a fresh system restore of my hard drive starting clean with Windows 7 64-bit. From there any time I tried to install Ubuntu from CD or Wubi no positive result, it just would not take the install.

It would look as though it would install but upon reboot, no GRUB, it would boot back into Windows like nothing was ever installed. I ended up installing virtual box and installed 11.04 in a virtual machine. Even then off top Unity would not load. After a few commands and restarts I got it working. I will be reverting back to 10.10 until a new update.

share|improve this answer

i assume that ur MBR is damaged. i think u can repair MBR to fix the problem. there are 2 methods to fix MBR.

  1. http://support.microsoft.com/kb/927392
  2. http://www.sevenforums.com/tutorials/20864-mbr-restore-windows-7-master-boot-record.html

first try method 1. its easy and simple. may be it works if not try 2.

if both doesn't work. try replacing wubildr.mbr file in C drive downloading a fresh file from net. hope this will fix ur problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.