Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

i am new to ubuntu 12.04 i am facing a lot of problem while installing vlc in my laptop every time i try to install it i get an error that the packages are broken. i have tried repairing, cleaning and removing the packages and also reinstalling it but all in vain.

i tried installing all packages manually but the same problem occured

sudo apt-get install vlc vlc-nox

i tried installing vlc using soft ware center but it showed the following error

This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.

The following packages have unmet dependencies:

vlc: Depends: vlc-nox (= 2.0.8-0ubuntu0.12.04.1) but 2.0.8-0ubuntu0.12.04.1 is to be installed
 Depends: libavcodec-extra-53 (>= 4:0.8-1~) but 4:0.8.9ubuntu0.12.04.1 is to be installed
 Depends: libavutil-extra-51 (>= 4:0.8-1~) but 4:0.8.9ubuntu0.12.04.1 is to be installed
 Depends: libc6 (>= 2.15) but 2.15-0ubuntu10.5 is to be installed
 Depends: libfreetype6 (>= 2.2.1) but 2.4.8-1ubuntu2.1 is to be installed
 Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is to be installed
 Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.1-0ubuntu4.4 is to be installed
 Depends: libqtgui4 (>= 4:4.7.0~beta1) but 4:4.8.1-0ubuntu4.4 is to be installed
 Depends: libsdl-image1.2 (>= 1.2.10) but it is not going to be installed
 Depends: libstdc++6 (>= 4.6) but 4.6.3-1ubuntu5 is to be installed
 Depends: libtar0 but it is not going to be installed
 Depends: libxcb-keysyms1 (>= 0.3.8) but it is not going to be installed
 Depends: zlib1g (>= 1:1.2.3.3.dfsg) but 1:1.2.3.4.dfsg-3ubuntu4 is to be installed

vlc nox shows following error

The following packages have unmet dependencies:

vlc-nox: Depends: liba52-0.7.4 but it is not going to be installed
Depends: libavcodec-extra-53 (>= 4:0.8-1~) but 4:0.8.9ubuntu0.12.04.1 is to be installed
Depends: libavformat-extra-53 (>= 4:0.8-1~) but 4:0.8.9ubuntu0.12.04.1 is to be installed
Depends: libavutil-extra-51 (>= 4:0.8-1~) but 4:0.8.9ubuntu0.12.04.1 is to be installed
Depends: libc6 (>= 2.15) but 2.17-93ubuntu4 is to be installed
Depends: libcddb2 but it is not going to be installed
Depends: libdvbpsi7 (>= 0.2.0) but it is not going to be installed
Depends: libebml3 but it is not going to be installed
Depends: libfontconfig1 (>= 2.8.0) but 2.10.93-0ubuntu1 is to be installed
Depends: libfreetype6 (>= 2.2.1) but 2.4.12-0ubuntu1 is to be installed
Depends: libgcc1 (>= 1:4.1.1) but 1:4.8.1-10ubuntu8 is to be installed
Depends: libgnutls26 (>= 2.12.6.1-0) but 2.12.23-1ubuntu4 is to be installed
Depends: libmatroska5 but it is not going to be installed
Depends: libmpcdec6 (>= 1:0.1~r435) but 2:0.1~r459-1ubuntu1 is to be installed
Depends: libmpeg2-4 but it is not going to be installed
Depends: libncursesw5 (>= 5.6+20070908) but 5.9+20130608-1ubuntu1 is to be installed
Depends: libpostproc-extra-52 (>= 4:0.8-1~) but 4:0.8.9ubuntu0.12.04.1 is to be installed
Depends: libresid-builder0c2a but it is not going to be installed
Depends: libsidplay2 but it is not going to be installed
Depends: libsmbclient (>= 3.0.24) but 2:3.6.18-1ubuntu3 is to be installed
Depends: libstdc++6 (>= 4.6) but 4.8.1-10ubuntu8 is to be installed
Depends: libswscale-extra-2 (>= 4:0.8-1~) but 4:0.8.9ubuntu0.12.04.1 is to be installed
Depends: libtwolame0 but it is not going to be installed
Depends: libudev0 (>= 147) but 175-0ubuntu9.4 is to be installed
Depends: libvcdinfo0 (> 0.7.23) but it is not going to be installed
Depends: libx264-120 but it is not going to be installed
Depends: libxml2 (>= 2.7.4) but 2.9.1+dfsg1-3ubuntu2 is to be installed
Depends: zlib1g (>= 1:1.2.0.2) but 1:1.2.8.dfsg-1ubuntu1 is to be installed

@avinash i tried the first command and got this

E: Some index files failed to download. They have been ignored, or old ones used instead. W: Failed to fetch http://ppa.launchpad.net/lucid-bleed/ppa/ubuntu/dists/precise/main/source/Sources 404 Not Found W: Failed to fetch gzip:/var/lib/apt/lists/partial/in.archive.ubuntu.com_ubuntu_dists_precise_universe_binary-amd64_Packages Hash Sum mismatch

share|improve this question

marked as duplicate by Seth, Braiam, karel, Eric Carvalho, Warren Hill Dec 3 '13 at 12:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2  
plz post the error report.Did you try sudo apt-get -f install? –  Avinash Raj Dec 1 '13 at 13:14
    
YES I DID.its been really frustatiing now.every time i do something it saysthat the packages are broken. –  sonakshi Dec 1 '13 at 13:24
    
After listening everything , the only easy way you got is to use "Synaptics" , if you have it well and good , otherwise open Ubuntu-Software-Ceter and search for it, after installing synaptics seach for vlc and install everything it selects , including other dependencies . it will definitely work and please be careful while using synaptics. –  Sushantp606 Dec 1 '13 at 15:20
    
@Sushantp606 i tried to install synaptic package manager too but it said that irs not available in my source code –  sonakshi Dec 1 '13 at 16:57
    
possibly as of now you have lost most of the libs, unfortunately its hard to recover each of them , you can do it manually with the consideration of error log, it will take a lot of time and work, so re-installing it is a better option , and at the time of installation connect to internet check to install third party SW and update then everything work for sure. I know its not the solution but it wont waste your time , cos as suggested by avinash you have done everything. –  Sushantp606 Dec 1 '13 at 17:03

1 Answer 1

Try these commands on terminal,

sudo rm -fR /var/lib/apt/lists/*
sudo sh -c "echo 'Dir::Ignore-Files-Silently:: \"(.save|.distupgrade)$\";' > /etc/apt/apt.conf.d/99ignoresave"
sudo apt-get update && sudo apt-get upgrade && sudo apt-get install build-essential
sudo apt-get install vlc vlc-nox
share|improve this answer
    
plz post the reason for -1? –  Avinash Raj Dec 1 '13 at 14:19
    
i didnt mark -1 to your ans. –  sonakshi Dec 1 '13 at 14:22
    
what error did you got after trying sudo apt-get update && sudo apt-get upgrade && sudo apt-get install build-essential –  Avinash Raj Dec 1 '13 at 14:24
    
plz post the errors in pastebin and provide the link here. –  Avinash Raj Dec 1 '13 at 14:28
    
@sonakshi i updated my answer plz see it. –  Avinash Raj Dec 1 '13 at 14:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.