Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How can I activate Unity?

Ubuntu 11.04 Unity desktop is not loading, instead it switches to "classic" mode. Is this something related to nVidia hardware? By the way, my card is a GeForce 210. Should I try to install the proprietary nVidia drivers?

share|improve this question

marked as duplicate by Marco Ceppi Apr 30 '11 at 14:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

You must install Nvidia driver if you want to use unity.Install appropriate driver form Hardware Drivers.After reboot unity will be loaded.

Edit

If you have Nvidia card and you cannot see any drivers for your card, you can use this PPA to install them right away. (this PPA works on 11.04 also) -

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current nvidia-current-modaliases nvidia-settings

and restart the system.

Source: http://www.linoob.com/2011/04/installing-ubuntu-11-04-and-testing-unity/

share|improve this answer

Have you tried to go to additional hardware and try using Nvidia current Drivers Have you tried to log out and see on the bottom of the login screen see if you have ubuntu classic as your desktop or you could try this CTRl ALT ESC brings you to tty type in sudo apt-get nvidia current i hope these suggestions help

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.