Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'll preface by saying the 'questions that may already have your answer' haven't helped me.

Ok, about a month ago I installed Ubuntu onto my Mac Mini, it worked. Then the Mac Mini went under my bed and sat there doing nothing for a month. I dug it out and put it in my flat's kitchen hooked up to the TV today and it appears to be dead.

When I turn it on, after the initial white Mac startup screen, the screen goes black, then a black screen with a white flashing dash appears. After that the screen goes to the purple 'Ubuntu 12.04' screen with 4 dots that each light up. After this, there is a lot of white (and some yellow) text, then the text stops scrolling and just stays for hours. When I begin holding the power button to turn the Mac off the text starts moving again until the computer is off.

It's driving me mad and I want it working before some flatmates get back tomorrow so I can continue watching movies in there.

Just to add, I no longer have an OSX partition. It's all Ubuntu, I do have a separate computer running Windows 8 which I can use for creating bootable USBs and such.

share|improve this question
Could you read the text ? If so, what did the last part say ? If you are really in a hurry you better start reinstalling instead of waiting for an answer. Unless your hardware is damaged, a new install should be ready within the hour. –  thom Dec 1 '13 at 0:57
The last part had the word 'brcmsmac' in it on all 4 lines, the last 4 lines were different from the rest. The rest of them just said things like starting and stopping various operations. I guess I could get exactly what the last 4 lines say if you would like. I would love to reinstall, but so far every bootable USB I create on my computer (Windows 8) doesn't show up in the Mac boot menu. –  user220900 Dec 1 '13 at 1:03
The more exact the report is, the higher the chance to pinpoint the problem. –  thom Dec 1 '13 at 1:06
'brcmsmac' is about ( wireless ) network –  thom Dec 1 '13 at 1:12
Have you tried booting while keeping the "c" ( or alternatively, the "apple-key" ) pressed, ? –  thom Dec 1 '13 at 2:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.