Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a C510 Logitech camera running 12.04. Looking up the list of cameras, this should just work out of the box, but it does not work in skype. lsusb gives this as the camera:

Bus 003 Device 003: ID 046d:081d Logitech, Inc. HD Webcam C510

Skype lists UVC Camera (046d:081d) (/dev/video0) but just show a black screen. It works perfectly in guvcview. Running locate v4l1compat.so gives:

/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so
/usr/lib/x86_64-linux-gnu/libv4l/v4l1compat.so

I've looked extensively on how to make this work and every suggested solution is:

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype 

which gives me:

`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:21326): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:21326): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:21326): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': skype: undefined symbol: menu_proxy_module_load

(skype:21326): Gtk-WARNING **: Failed to load type module: (null)

however when I use

sudo env LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype

it works but when I go to test the video in skype, I get:

libv4l2: error turning on stream: Input/output error

I'm not sure what exactly I need to do to make this work in skype. Am I missing something obvious? Please help.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.