Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Today I installed Ubuntu for the very first time. I am having trouble installing any drivers for my GT 720M card.

I've tried to follow the guides for general NVIDIA driver installation but haven't had any success. Likewise, the "additional drivers" program fails to detect anything.

I would really appreciate any instructions to be typed out in baby-steps. Traditionally, I'm a Windows user, and I'm unfamiliar with what are, probably, basic operations.

share|improve this question

marked as duplicate by Braiam, Warren Hill, Alvar, Eric Carvalho, mikewhatever Dec 25 '13 at 6:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Are you running 64bit or 32bit? you can see that by running uname -a on terminal. –  Achu Nov 30 '13 at 17:58
2  
Most possibly your card is a hybrid card. See -How well do laptops with Nvidia Optimus work? –  Web-E Nov 30 '13 at 18:09
    
I'm running 64bit –  Sam Nov 30 '13 at 18:23
    
Is there any problem right now with the drivers you have installed? –  Braiam Nov 30 '13 at 18:48
    
'Under system setting - details - Graphics' there is no information –  Sam Nov 30 '13 at 18:49

1 Answer 1

Add this ppa repository: https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

To do that, open the Terminal and type (in this order):

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates 
sudo apt-get update

When you type the first command, you will be asked to type your password. (Note that while you are typing your password you won't see anything on the screen. Don't worry: that's normal.)

Then try to open "additional drivers" again and check if it finds any driver.

PS: to learn what Repositories and PPAs are, take a look here: https://help.ubuntu.com/community/Repositories/Ubuntu

PPS: Welcome to Ubuntu and GNU/Linux ;)

share|improve this answer
    
I did some research and I think that the driver version in that repository is too old for your GPU. Try that anyway. If it doesn't work I'll suggest you another PPA. –  korg91 Nov 30 '13 at 18:30
    
Hi, thanks for your help. I followed the two commands but the additional driver list is still empty. –  Sam Nov 30 '13 at 18:48
    
Ok, then first remove the previous ppa using this command: sudo add-apt-repository --remove ppa:ubuntu-x-swat/x-updates Then try with this ppa: launchpad.net/~xorg-edgers/+archive/ppa So, like before: sudo add-apt-repository ppa:xorg-edgers/ppa and sudo apt-get update and then check "additional drivers" again. –  korg91 Nov 30 '13 at 18:52
    
While trying to remove the previous ppa, I got an error message saying "...doesn't exist in sourcelist file". –  Sam Nov 30 '13 at 19:07
    
This is strange... Are you sure you actually added the x-swat ppa? Did you notice that when you add a ppa, after a while it asks you to confirm by pressing ENTER? If you open "Software & Updates" and click to "Other Software", do you see that ppa in the list? –  korg91 Dec 1 '13 at 10:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.