Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm pulling my hair trying to get this out.

Since I know there is an issue with bumblebee and my laptop I've installed one of the latest stable kernels, so uname -r gives me 3.12.1-031201-generic

Now lspci -nn | grep '\[030[02]\]:' shows

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
01:00.0 3D controller [0302]: NVIDIA Corporation GF117M [GeForce 610M/710M / GT 620M/625M/630M/720M] [10de:1140] (rev a1)

But still unable to run optirun, with throws (optirun -vv firefox):

[ 1029.729132] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 1029.729505] [INFO]Configured driver: nvidia
[ 1029.729560] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 1029.729567] [DEBUG]Socket closed.
[ 1029.729579] [ERROR]Could not connect to bumblebee daemon - is it running?

The nvidia drivers I'm trying to use are nvidia-319-updates, just in case olders won't recognize my GPU

I don't know wich other info could be important, here are is more info.

sudo lshw -C video

  *-display UNCLAIMED     
       description: 3D controller
       product: GF117M [GeForce 610M/710M / GT 620M/625M/630M/720M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:d2000000-d2ffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:3000(size=128)
  *-display
       description: VGA compatible controller
       product: 3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:46 memory:d3000000-d33fffff memory:e0000000-efffffff ioport:4000(size=64)

Bumblebee.conf:

Driver=nvidia

[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia-319-updates
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-319-updates:/usr/lib32/nvidia-319-updates
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-319-updates/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

If I do a modprobe nvidia i get:

vivo@vivoPC:~$ modprobe nvidia
FATAL: Module nvidia not found.
vivo@vivoPC:~$ modprobe nvidia-319-updates
FATAL: Module nvidia_319_updates not found.

Please, tell if you need any more info

share|improve this question
    
A few questions have been already asked with similar error messages. Try searching for [bumblebee] daemon, and see if this helps or add links to related but not helpful questions. –  krlmlr Nov 30 '13 at 21:45

2 Answers 2

This is from the docs:

In order to use Bumblebee it is necessary add yourself (and other users) to the bumblebee group:

# gpasswd -a $USER bumblebee

where $USER is the login name of the user to be added. Then log off and on again to apply the group changes.

Is your user in the bumblebee group? (You can use this command "as is", normally $USER will expand to the currently logged-in user. Have to execute it as root though -- just for setting up, not for using optirun.)

share|improve this answer
    
Thanks for trying to help, i finally made it –  vivoconunxino Nov 30 '13 at 23:46
up vote 0 down vote accepted

Ok, all those users with a lenovo or any new laptop with problems detecting your two devices:

All those instructions are on a fresh install. (yes, I reinstalled it...again)

- Update your kernel to a 3.9 or highter

Instructions (thanks to Mitch):

To install Linux Kernel 3.9.4, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get autoremove
cd /tmp
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9.4-saucy/linux-headers-3.9.4-030904-generic_3.9.4-030904.201305241545_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9.4-saucy/linux-headers-3.9.4-030904_3.9.4-030904.201305241545_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9.4-saucy/linux-image-3.9.4-030904-generic_3.9.4-030904.201305241545_i386.deb
sudo dpkg -i *.deb
sudo update-grub2

For 64bit, just change:

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9.4-saucy/linux-headers-3.9.4-030904-generic_3.9.4-030904.201305241545_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9.4-saucy/linux-headers-3.9.4-030904_3.9.4-030904.201305241545_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9.4-saucy/linux-image-3.9.4-030904-generic_3.9.4-030904.201305241545_amd64.deb

Note: You may have to restart your computer after the first command.

- Install bumblebee rigurously as it says bumblebee's main page

Bumblebee Project

Important the part where you have to edit the /etc/bumblebee/xorg.conf.nvidia (or /etc/bumblebee/xorg.conf.nouveau if using the noveau driver) and specify the correct BusID by following the instructions therein.

This means, uncomment the # BusID "PCI:01:00:0" line (remove the '#') if your 3D card is in that bus (find it out with lspci | egrep 'VGA|3D').

- Install primus (thanks to webupd8 dot org)

sudo apt-get install primus

64bit: you also need to install "primus-libs-ia32:i386" (note that if you're using the Primus PPA, the package you need to install is "primus-lib:i386"):

sudo apt-get install primus-libs-ia32:i386

Then, change the "Bridge" option in /etc/bumblebee/bumblebee.conf to "primus". You can also directly call Primus from optirun via command line, like this:

optirun -b primus APP

- Test it

optirun glxspheres
optirun -b primus glxspheres

Hope this may help any lost soul

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.