Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I set the launcher to always show in Unity 2d?

I'm using unity-2d in ubuntu 11.04 since 3d version is not working good in virtual machines (i use virtualbox from MacOS X). All works fine except auto-hide.

With windows and Mac OS i get user for taskbar to be permanently on the screen - so i have issued "gconf-editor" and changed auto-hide for unity from "2" to "0". This stops it from hiding, but now all windows that i start (firefox, explorer etc) completely ignores unity taskbar and alignes themself on the left side of screen as if taskbar is hidden :(.

Is it any way to fix it and make fullscreen / newly created windows to correctly align themselves on the right side of taskbar and not ignore it?

share|improve this question
add comment

marked as duplicate by Oli Oct 13 '11 at 22:50

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

up vote 2 down vote accepted

Alan's answer doesn't work on Unity 2D because it doesn't use Compize.

If I got you right this might be the solution for your question: In gconf-editor enable "use_strut" in Unity 2D's settings (desktop -> unity-2d -> launcher). In addition Mariano Chavero has made "A simple GUI for Unity-2D Settings": http://marianochavero.wordpress.com/2011/04/20/a-simple-gui-for-unity-2d-settings-ubuntu-11-04/

share|improve this answer
    
Thanks, that completely solves a problem. The name "use strut" is very... surprising. What is "strut"? O_O –  Eye of Hell May 2 '11 at 16:17
    
In this case it means something like "to move away from the left border of the screen" (see en.wiktionary.org/wiki/strut) –  user13281 May 3 '11 at 10:54
add comment
  1. Install CompizConfig Settings Manager.

    sudo apt-get install compizconfig-settings-manager

  2. Navigate to the Ubuntu Unity Plugin tab.

  3. Change Hide Launcher to Never, and go back.

  4. Scroll down to the Place Windows tab.

  5. Experiment with the Placement Mode until you find what you are looking for.


I don't have Unity, otherwise I would know what Placement Mode you need.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.