Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A few weeks ago I set my computer up to dual boot Ubuntu 13.10 and Windows 7 Pro. Everything worked fine, but I found the hassle of switching between OSs annoying. Since I prefer Windows 7 I decided to get rid of Ubuntu. Of course, since I'm such a lazy, stupid person I thought "I'm sure if I just delete the partition that I download Ubuntu on everything will just magically work like it use to." So I went into the partition manager for Windows, deleted the Ubuntu partition, and merged the deleted partition to my files partition.

Ladedadeda, everything was working fine. I go to restart for updates, lo and behold I can't boot into Windows! I'm pretty decent at troubleshooting and so my first thought was to start searching for a way to fix my problem online. My first attempt at solving the problem was reinstall Ubuntu and set up dual-boot again. Unfortunately, every option I was given at the GRUB worked except Windows 7, and I got the message "error: EFI file path not valid". Well, at least I can use Ubuntu on my computer now. My second attempt at to solve the problem was to download boot-repair and execute the program. This didn't do much other than give me the error, invalid arch independent ELF magic when ever I tried to boot into Windows 7. It also didn't get rid of the previous error message either. Thirdly, I went to create a LiveUSB Windows repair disc to fix the MBR and set partition 1 (System Reserve for Windows) to active. I was able to run the repair disk, but it didn't change anything. Then I come across some advice suggesting that I should re-reinstall Ubuntu, just in case I the GRUB is in EFI mode instead of BIOS or something along the lines of that. Anyway, I go to do that using the same USB flash drive I used before to install Ubuntu and wiped to create the Windows 7 repair disk and of course my USB flash drive just isn't being recognized as a USB flash drive or a drive at all by the software. Interestingly enough, Ubuntu still recognizes it, and I can reformat and wipe it (which I've done several times) and move/copy/paste files to and from it.

After hours of troubleshooting and looking up guides, I still can't solve this problem. If anyone could fix this problem I'd greatly appreciate it. And finally, If you need any further details go ahead and ask.

P.S. I'm expecting a SSD for Xmas so I might just find a copy of Windows 7, install it on that, and have all my files/media on my HDD, if that works.
P.P.S. Is it just me or does it look like there is hardly any space between periods and the following character?

share|improve this question
2  
It is hard to read a question that you can't really read more than half of... A fresh install may to a new SSD could be good idea... If you can't bothered to write the question properly, I don't think anyone will bother to answer it. –  Wilf Nov 29 '13 at 23:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.