Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have running Ubuntu 12.04 with kernel 3.8

I have tried many suggestions, although, the backlight is still not working. If I try to use the most simple solution:

echo  | sudo tee /sys/class/leds/asus::kbd_backlight/brightness

I get the following message:

tee: /sys/class/leds/asus::kbd_backlight/brightness: No such file or directory


ls /sys/class/leds/


Thats all I have. Any kind of help is very much appreciated!

share|improve this question
I got a step closer to the solution. asus::kbd_backlight is created by asus-laptop module. If I try modprobe -v asus-laptop I got back: insmod /lib/modules/3.8.0-33-generic/kernel/drivers/platform/x86/asus-laptop.ko FATAL: Error inserting asus_laptop (/lib/modules/3.8.0-33-generic/kernel/drivers/platform/x86/asus-laptop.ko): No such device. I tried already set acpi_osi=Linux without any effect. –  Lolo Dec 8 '13 at 20:52
Actually, the module asus-nb-wmi should creating asus::kbd_backlight . After modprobe asus-nb-wmi I get ` Asus WMI hotkeys as /devices/platform/asus-nb-wmi/input/input11` and asus_wmi: Backlight controlled by ACPI video driver . No error messages. However, there is still no asus::kbd_backlight created. –  Lolo Dec 9 '13 at 22:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.