Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ubuntu along with windows8. Recently I upgraded to windows8.1. After that I am not getting the grub, which i used to get with windows 8. But i can access ubuntu 13.04 by pressing F9 while starting and in boot options, ubuntu, then i get grub and i can access ubuntu. Files are as usual. I tried to run boot repair but its rectifying this problem.

http://paste.ubuntu.com/6393514 It says, The boot files of the OS now in use-ubuntu 13.04 are far from the start of the disk. Your bios may not detect them. I dont have idea whar it is. Can anyone help on the same?

share|improve this question
    
    
Guessing from your pastebin log that grub is in sda6 - meaning that it is in the 6th partition from the start of the disk, which is what causes the error - Windows for some reason seems to have 5 or 6 of the partitions on the hard disk. The bootloader will search for a boot file thing from the beginning of the disk, but the Windows one is in sda4, meaning that it will pick that before it has even found grub - updating grub may help, but this is probably Windows doing what it does best - being stupid + evil, so it will be hard to sort out. –  Wilf Nov 29 '13 at 19:58
    
possible duplicate of Cannot Restore Grub After Windows 8.1 Upgrade –  bain Jul 5 at 1:26

4 Answers 4

I got it back when I changed chose back up EFI files option in advanced boot repair option.

share|improve this answer

Boot into the BIOS screen. Check the "Startup Order" tab, there you'll see Windows Boot Loader in position 1.

Change the order so "ubuntu" is in the first position.

I just recovered my partition this way.

share|improve this answer

On my Samsung Series 9, changing the booting order (promoting "ubuntu" in first position) did not work: the order with the Windows Boot Loader in first position was restored after every reboot.

Here's what worked:

  • Boot into the BIOS setup (F2)
  • Go to Boot --> Boot device priority
  • In the boot priority order, go to "Windows Boot Manager" (which should be in position 1) and disable it (Shift + 1)
  • Save BIOS settings and reboot

You should now have your GRUB menu back, from which you can boot Windows or Ubuntu Linux.

share|improve this answer

If you can access ubuntu, reinstall grub:

Note than in my example, I have grub installed in the first hard drive. Your installation may be different (sdb for example):

sudo grub-install /dev/sda

If you're not sure which one to use:

sudo fdisk -l

Will show you the devices and partitions you have.

After installing grub, update it:

sudo update-grub

Good luck!

share|improve this answer
    
It didn't work. When I ran boot repair, after its successful completion, it says, "The boot files of[The OS now in use-Ubuntu 13.04]are far from the start of the disk. Your BIOS may not detect them. You may want to retry after creating a /boot partition (EXT4,>200MB, start of the disk). This can be performed via tools such as gParted. Then select this partition via the [Seperate /boot partition:] option of [Boot repair]." I don't understand how to do. –  Nitin Nov 30 '13 at 9:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.