Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just installed natty. When running the Live session the wireless was working perfectly. After installation however, it doesn't work at all. There is an option to install the Broadcom Restricted drivers, but when I click activate, I just get a "jockey" error, pointing me to /var/log/jockey.log.

This is what that file contains:

2011-04-30 11:31:15,648 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2011-04-30 11:31:15,686 DEBUG: XorgDriverHandler(%s, %s).enabled(): No X.org driver set, not checking
2011-04-30 11:31:15,849 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2011-04-30 11:31:15,884 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2011-04-30 11:31:15,918 DEBUG: XorgDriverHandler(%s, %s).enabled(): No X.org driver set, not checking

This is the only issue I'm having with Natty, I'm hoping someone can help me fix this (if it's not a bug).

share|improve this question
1  
Right, so I managed to fix this. I found this page had instructions on installing the broadcom drivers.I opened up synaptic package manager, and found that these drivers were already installed. So I marked it for "re-installation" and applied. Restarted the computer. After restart, the wireless was available to choose from, but it didn't pick up any networks. So I Openend the "Additional Drivers" app from the System Settings, and Removed, and then Re-added them. –  Andre Apr 30 '11 at 11:14
    
Good deal Andre. Glad you got it working. This type of thing is most often (in my experience) some weirdness with installing and your only network is wireless. The installer thinks it should go get the restricted drivers, but doesn't realize that is the primary connection so... You may want to move your comment down to the answers section and accept it. –  hbdgaf Apr 30 '11 at 12:27
    
welcome to Ask Ubuntu! Please answer your question by posting it as answer below so that we can vote on it and that you can accept it as the solution so the next person can benefit, thanks! –  Jorge Castro May 1 '11 at 19:02
    
the "reinstall package and enable driver" approach worked for me as well! Don't forget to do run both the modprobe commands on the link that Andre posted. –  jrharshath Jun 19 '11 at 13:50

2 Answers 2

I have the same wireless network card; i.e. "Broadcom Corporation BCM4311" (possibly your model may be different, which can be determined by "lspci -vvnn | grep 14e4" command in the terminal), and the same problem (no wireless connection, even I cannot see the list of wireless networks) after the 11.04 upgrade.

My problem is solved after removing "bcmwl-kernel-source" by using Synaptic Package Manager, then installing "firmware-b43-installer" and "b43-fwcutter" again by Synaptic Package Manager. I hope it solves your problem, too.

share|improve this answer
    
+1 worked for me –  alfC May 1 '11 at 22:28
    
Worked for me too. Thanks. –  marenostrum May 4 '11 at 17:18

WiFi not working (Broadcom BCM4311 )

Bug report is here.

Wireless + Linux has a long long way to go.

You should submit a bug report. The more reports the quicker something will get done (in theory).

In the meantime you can experiment with blacklisting modules and downloading a driver from Broadcom's website directly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.