Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm a new user of Ubuntu 13.10 so far so I don't have too much technical expertise. I recently tried to resolve a Skype installation issue and added some ppa involving binary-1386. Every time when I run sudo apt-get update, I get the following error:

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/saucy/Release  Unable to find expected entry 'restricted/binary-1386/Packages' in Release file (Wrong sources.list entry or malformed file)
W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/saucy/Release  Unable to find expected entry 'main/binary-1386/Packages' in Release file (Wrong sources.list entry or malformed file)
... (can't post more than 2 links here since I'm a new poster)
...
E: Some index files failed to download. They have been ignored, or old ones used instead.

I have spent the last two hours trying to resolve this issue, and made changes to my sources.list file by resetting to the default saucy settings, but these errors are still occuring. I've also unchecked everything in Software and Updates section, but this still seems to appear. The error messages seem to be related to the 'binary-1386/Packages' in Release file (Wrong sources.list entry or malformed file) issue as shown above.

share|improve this question
1  
Perhaps because you have a "1" instead of an "i" in the entry? main/binary/-i386/Packages –  douggro Nov 29 '13 at 6:53
    
How do I change '1' to 'i' in main/binary? Thanks, that maybe the issue! –  ggoober Nov 29 '13 at 7:03
    
which ppa did you add? –  Avinash Raj Nov 29 '13 at 7:13
    
edit your question and add the output of cat /etc/apt/sources.list /etc/apt/sources.list.d/*. Do not use comments. –  Braiam Nov 29 '13 at 15:27

1 Answer 1

Open the sources files and search for binary-1386 and replace 1 by i then save..

Sources files are found either in

/etc/apt/sources.list

and/or you can find many files inside the directory

`/etc/apt/sources.list.d/`

now open the sources file with sudo and edit

sudo gedit /etc/apt/sources.list 

and/or

sudo gedit /etc/apt/sources.list.d/****.list
share|improve this answer
    
Thanks to douggro's suggestion. I backtracked what I did today: I was following the Skype instructions on help.ubuntu.com/community/Skype And used sudo dpkg --add-architecture 1386 instead of 'i386'. I did a quick search on how to remove dpkg and removed the 1386 that was added, and now everything works! Thanks for all your help though (the issue wasn't in sources.list or sources.list.d since I was struggling with those answers found in other threads). I'm new to Linux/Ubuntu but glad the community's so responsive and helpful so far. Thanks!! –  ggoober Nov 29 '13 at 7:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.