Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install maybe ten Linux distros on my new PC, and every time I have problems with video driver: black screen or visual artefacts.

I was able to install only Ubuntu 12.04.3 x64 LTS, but also with problems: black screen on startup (sometimes all was normal when I used Live mode before install, sometimes I was not able to load Live Mode - Ubuntu say that I have problems with video and give me choice with four elements, one of them - use safe graphics mode, but I even can't choose this - the system is frozen).

In tty I install nvidia-current, but it not helped me. Every boot I need press ESC and enter to rescue mode and just press Resume and after this normal boot work. If I try to make normal restart - black screen after Ubuntu logo again and for normal work I need again go to rescue mode (just press Reset - Ubuntu automaticaly will load rescue mode).

I tried switch nvidia driver in options - I have version 319-updates and version 319 [Recommended] - nothing.

I have Palit GeForce GTX650, all updates.

My dmesg output.

My output of dpkg --get-selections | grep 'nvi\|nou'.

My /boot/grub/grub.cfg

share|improve this question
    
did you blacklist or uninstall the Nouveau driver? –  Anders F. U. Kiær Dec 11 '13 at 19:40
    
Not uninstall. I need? –  Vitaly Zdanevich Dec 11 '13 at 20:11
    
could be worth a try, sudo apt-get --purge remove xserver-xorg-video-nouveau –  Anders F. U. Kiær Dec 11 '13 at 20:20
1  
can you add the output of dpkg –get-selections | grep 'nvi\|nou' to the question and the output of dmesg to paste.ubuntu.com and add the url in the question? –  Anders F. U. Kiær Dec 12 '13 at 14:56
1  
Could you please post your /boot/grub/grub.cfg? I think you miss the nomodset kernel parameter from your kernel command line. –  falconer Dec 14 '13 at 7:43

4 Answers 4

up vote 1 down vote accepted

The proprietary nvidia driver should be used without KMS. You have to edit the /etc/default/grub file, use your favourite text editor (vi, nano, gedit, etc.):

sudo vi /etc/default/grub

Change the GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" line to the following:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Save the file, then run sudo update-grub Then reboot, and it should work.

If it still doesn't solve it, then remove also "quiet splash" from the previous line, and again sudo update-grub. (This will disable the graphical boot screen.)

The recovery booting did work, because the recovery menu entry had the nomodeset parameter.

share|improve this answer
    
First normal boot for my new PC! Thank you! –  Vitaly Zdanevich Dec 18 '13 at 13:24
    
It is not important, but I can't enter into tty when pressing CTRL+ALT+F1: I see only black screen and after few seconds my display turn off. –  Vitaly Zdanevich Dec 19 '13 at 8:44
    
@VitalyZdanevich Please add the vga=normal parameter also to that line. If still no good add the video=vesa:off parameter also. Note that after this you tty resolution will be decreased, but this can't be resolved with the nvidia drivers AFAIK, which only supports text mode tty. If still no success remove quiet splash to disable graphic boot. –  falconer Dec 19 '13 at 9:23
    
I don't know - it's related to this problem or not, but now I can't shut down my PC - my computer rebooting instead of power off. –  Vitaly Zdanevich Dec 22 '13 at 19:42
    
@VitalyZdanevich It shouldn't cause such problems, all of these kernel parameters only deal with display. But the best is to test and try out with different parameters and see if one of these are the faulty one. What kernel parameters are you using now? You may also try adding the "acpi=force" kernel parameter. (or maybe the contrary acpi=off"). Or try disabling wake-on parameters in the BIOS. (wake-on-lan, wake-on-key,etc.) This is what you could try in my opinion. If none of these solves your problem, then ask another question on the site. –  falconer Dec 22 '13 at 20:35

I had same problem with 2 laptops with similar nvidia cards.

The solution I have found after trying many ubuntu flavors with similar problem is to install fresh kubuntu, and then, before you perform any software updates, use synaptics, filter for nvidia and go to package / force version and keep nvidia filtered packages to the installed version in order to prevent them from upgrading.

Then, you can install other desktop flavors if you want (I have tested adding in second step my favorites gnome & xfce without any problems). I think, if my memory serves me well, the nvidia driver used and kept using is 173.x (or 176.x).

Hope it helps :)

share|improve this answer

This is X Server error. If X Server update itself then it will also delete the path of the graphic driver. The only way perhaps is to install what Ubuntu has to offer (namely drivers in 'Additional Drivers').

I have AMD A10 with AMD Radeon HD8650 with CrossFire AMD Radeon HD 8970m and installed a driver found in AMD websites, after an updates, the X server failed. I have to reinstall 'fglrx' (AMD drivers for Ubuntu) and the X server works again, only this time, it couldn't identify my 8970m, but identify it as other AMD GPU.

I'm not sure about nVidia, but my advice is try not to install anything beyond what Ubuntu gave you. If it's from Ubuntu, higher chances are it will work.

share|improve this answer
    
Ubuntu not offering me anything - I already have installed from tty Nvidia driver. –  Vitaly Zdanevich Dec 7 '13 at 15:04

So this GTX650 Geforce card of Nvidia has CUDA-Technology as I see in description at website of nvidia.com

Here I posted a workaround for CUDA-cards, which normally refers to Ubuntu 12.10 and worked there fine:

How can I Install Nvidia Driver GT 520 and Cuda 5.0 in Ubuntu13.04?

It is humblesome, but not too tricky.

This workaround normally concerns hybrid-cards of nvidia, but I don't see, why it should not work with your card.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.