Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have heard that installing or running .tar.gz files is possible. This is a source code, also and if there is a difference I should be told about it. The game is http://www.knightsgame.org.uk/files/knights_022_src.tar.gz. Success would be great. This is a good game, It would be appreciated. ;)

Followed mikewhatever's directions below but ran into:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libsdl1.2-dev' instead of 'libsdl-dev'
Note, selecting 'libfontconfig1-dev' instead of 'libfontconfig-dev'
build-essential is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

    The following packages have unmet dependencies:
     libcurl4-gnutls-dev : Depends: libcurl3-gnutls (= 7.22.0-3ubuntu4.2) but 7.22.0-3ubuntu4.3 is to be installed
                           Depends: libgnutls-dev but it is not going to be installed
                           Depends: libldap2-dev but it is not going to be installed
                           Depends: librtmp-dev but it is not going to be installed
     libfontconfig1-dev : Depends: libfontconfig1 (= 2.8.0-3ubuntu9) but 2.8.0-3ubuntu9.1 is to be installed
     libsdl1.2-dev : Depends: libx11-dev but it is not going to be installed
                     Depends: libglu1-mesa-dev but it is not going to be installed
                     Depends: libpulse-dev but it is not going to be installed
                     Depends: libxt-dev but it is not going to be installed
                     Depends: libxext-dev but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

apt-get autoclean removed the held packages.

This sends me looking for repositories but the curl and libcurl repositories are without libcurl4-gnutls-dev.

share|improve this question

marked as duplicate by mikewhatever, Rinzwind, Avinash Raj, BuZZ-dEE, don.joey Dec 20 '13 at 11:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Here is a good howto. The list of dependencies is here. –  mikewhatever Nov 29 '13 at 3:23
    
@mikewhatever helpful thanks, I am having trouble with translation from french Ubuntu. –  Diogenes Lantern Nov 29 '13 at 4:50
    
Difficult to understand? Check out the answer. –  mikewhatever Nov 29 '13 at 6:42

1 Answer 1

I've not installed the game, and don't know if it works, but the steps to build that particular source code should be as follows:

  • Extracting

Right-click the downloaded file, select 'Extract here'.

  • Installing dependencies

Open a terminal window (ctrl-alt-t in Ubuntu), and the command below. It will install quite a few additional files.

sudo apt-get install build-essential libboost-dev libboost-filesystem-dev libboost-system-dev libboost-thread-dev libsdl-dev libcurl4-gnutls-dev libfreetype6-dev libfontconfig-dev
  • Installing

Still in a terminal window, change to the source directory with cd knights_022_src, then run make, and wait. If it finishes without errors, run sudo make install.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.