Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Ubuntu 12.04 server on a DMZ and a Windows server on an internal network.

Now I need to mount a folder of the Windows server on my Ubuntu server. I use the mount command and all goes fine... but after some time if I try to open the Ubuntu folder where the mount is, I can't.

The folder is in /media, so I run cd /media but when I run the ls command it sticks and the terminal is frozen. In order to access the folder again I have to umount it. Then if I try to mount again the mount command sticks and I have to do Ctrl + C to close it. At that point the only thing I can do is reboot Ubuntu, and when server is up I find the mounted folder correctly, because it is in fstab.

I have another Ubuntu machine with another share on same Windows server, and has worked fine for months, so I don't understand what the problem can be.

The fstab entry is the same on both Ubuntu servers:

//192.168.20.8/shared/Flusso_Homebox /media/Flusso_Homebox smbfs auto,username=xxxx,password=xxxx,file_mode=0777,dir_mode=0777,rw 0 0
share|improve this question
    
It may be helpful to edit your question to include the line from /etc/fstab for the folder that is breaking, and also the line from the other machine that is working. –  David Edwards Nov 29 '13 at 8:33
    
the lines are identical (i copied it) except for the user and password...however this is line with strange behaviour: //192.168.20.8/shared/Flusso_Homebox /media/Flusso_Homebox smbfs auto,username=xxxx,password=xxxx,file_mode=0777,dir_mode=0777,rw 0 0 –  Alessandro Nov 29 '13 at 9:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.