Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Here is my situation:

  • I installed Xubuntu 13. 10
  • I added the Cinnamon PPA and installed Cinnamon 2. 0
  • I removed all the GNOME stuff, that came with Xubuntu
  • Everything went fine so far...but...

These are my settings:

  • In my Power settings the following is set:
  • When lid is closed (on battery):suspend
    • When lid is closed (on AC):do nothing
    • In my lock settings I set that there should be a password prompt, after going to suspend/waking up

Now this strange behaviour:

If I close my lid, be it on battery or on AC power, the notebook suspends. But after waking it up, there is no password prompt. If I manually activate suspend mode (special key on keyboard/system menu) there is a password prompt after waking up.

My question: Why is this happening? Why does the power daemon (there is only "upowerd" running) ignores my power settings? What software/settings has to be installed/set to make this work properly?

share|improve this question
Perhaps it's a bug, has them. Have you tried those settings on the default Xubuntu install? – mikewhatever Nov 28 '13 at 16:34
Are you absolutely sure there are not two different settings applications and one is conflicting with the other? – Devyn Collier Johnson Nov 28 '13 at 16:37
@DevynCollierJohnson How do I find out? If I grep my processes list for "settings" there is only "cinnamon-settings-daemon" running. – Felix Haller Nov 28 '13 at 17:42
@FelixHaller look under "Applications -> Settings", the System menu, and other similar app menus. – Devyn Collier Johnson Nov 28 '13 at 20:11
Ok...I think it's a bug, cause I found this one: – Felix Haller Nov 29 '13 at 9:49

Ok I found a (workaround?)-solution in a german forum:

You have to edit the file /etc/systemd/login.conf and uncomment/modify the following two lines:


That solved the issue for me and the system no longer ignores my cinnamon settings.

share|improve this answer

This is already a bug issue, so it will be solved sometime in the future. For now there is and official workaround:

"This can be adjusted in /etc/systemd/logind.conf. Just set HandleLidSwitch and other the events you want handled by systemd to ignore - you have to delete # in the beginning of the respective lines, save, close the file, and restart."

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.