Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

do you know any workaround for this very long lasting bug buried somewhere in kernel or in gnome-power-manager, please? Thanks in advance. See description:

https://bugzilla.gnome.org/show_bug.cgi?id=579224

share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 17:09

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
IIRC, this is the same problem as with volume buttons on some ThinkPads... the hardware just does it and then also sends out a signal saying the button's been pressed. Possibly you could unset the shortcut in System -> Preferences -> Keyboard Shortcuts for this action? –  maco Sep 15 '10 at 16:12

2 Answers 2

as a workaround suggest the "brightness" applet in gnome

http://library.gnome.org/users/gnome-power-manager/stable/applets-general.html.en

share|improve this answer

Seems to work fine on 11.04, with a Thinkpad T42.

The reason, as given above, is that the version of the thinkpad_acpi module that you have is not masking the brightness hotkeys correctly. This means that when you press a hotkey for brightness up or down, the bios grabs it, changes the brightness and also produces an ACPI event. The acpi drivers then generate a virtal keypress, something like X86FreeBrightnessUp, or whatever it is. The gnome power manager responds to this perceived keypress by increasing the brightness again.

Upgrade, or do a search for thinkpad_acpi hotkey mask and change the default mask to one that masks the brightness hotkeys.

You find similar issues for volume, though in that case it is due to the hardware and software mixers both being increased by the same button.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.