Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Aspire V5 571G with qualcomm atheros wireless adapter. It takes to long to connect to a wi-fi network about 1 min and even when it's connected there is no internet. I'm on Ubuntu 13.10 Thanks :)

ip config:

eth0      Link encap:Ethernet  HWaddr 20:6a:8a:db:0e:49  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:3502 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3502 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:429534 (429.5 KB)  TX bytes:429534 (429.5 KB)

wlan0     Link encap:Ethernet  HWaddr 20:68:9d:36:5f:95  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::2268:9dff:fe36:5f95/64 Scope:Link
          RX packets:11713 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11341 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8923692 (8.9 MB)  TX bytes:1594202 (1.5 MB)
share|improve this question
We need more details like sudo ifconfig to see if you are getting an IP Address or not. – K2Chris1983 Nov 27 '13 at 23:17
I edited my answer. Also after several restars and turninng on/off wifi i was able to connect after (60 sec ore more and several attempts) and i have internet . but if I restart or shut down the same problem again :) – Rexhin Hoxha Nov 27 '13 at 23:49
How have you set up your connection? DHCP or static, by hand? Can you post your route -n, too? – 0xAffe Nov 28 '13 at 7:39

I had a similar problem until recently - an excellent Wi-Fi signal, but no Internet connection. In order to be sure, I configured the router several times and the result was the same. In fact, I have two routers of different models, an TP-Link and an ASUS, I have tried with both of them, and got no result. Thinking that I may do things wrong, I have asked two PC-skilled and experienced friends to help me - they spend hours trying and, I think you guess, no results.

So, at the end, I have concluded that the problem it is not my devices or settings, but somewhere else. So I did several long and annoying phone calls to my internet service provider, and, at the end, it resulted that, the problem was originated from them. After talking with one of their experts, (who reviewed my net connection), I did a reset of my Wi-Fi connection and now it works flawlessly.

So, my advice is to try to reset the connection for several times, and even to try several router models. If none of this works, you should make a call to your internet service provider, because it just may not be your devices fault.

I am not sure if that is the answer you are looking for, but I do hope that my experience will help you.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.