Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to build matplotlib from source but it isn't working. It seems this thing was a part of X11, and since Ubuntu is now using Wayland that screwed things up, I think.

Anyway to fix this?

Oh, ok. I just had to install libfreetype6 and libfreetype6-dev with apt-get. I can't answer it now so I'll edit it later or something.

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

I found these dependencies in the install file:

  matplotlib core: zlib, zlib-devel, libpng, libpng-devel,
                   freetype, freetype-devel, freetype-utils

  gtk backend: gtk2-devel, gtk+-devel, pygtk2, glib-devel,
               pygtk2-devel, gnome-libs-devel, pygtk2-libglade

  tk backend: tcl, tk, tkinter

Do you have all those installed?

share|improve this answer
    
I have now! Truth be told I realized now that they tell you in the matplotlib page that you need libpng and freetype but I guess I just skipped that part. Thanks anyway though. –  ruh roh Apr 30 '11 at 5:32
add comment

I should install libfreetype-dev (Ubuntu).

share|improve this answer
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  don.joey Mar 26 '13 at 11:12
1  
OP has already clarified in an edit that the issue is solved: Oh, ok. I just had to install libfreetype6 and libfreetype6-dev with apt-get. –  user25656 Mar 26 '13 at 11:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.