Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having some issues with removing an iptable entry I have entered.

I added

-A PREROUTING -d 95.211.213.149/32 -i venet0 -p tcp -m tcp --dport 443 -j REDIRECT --to-ports 1194

To experiment with putting openvpn traffic over 443 but it failed i did not like the results.

My 443 traffic to my web server is no longer working as i can not seem to get rid of this rule.

I have attempted to remove the rule from /etc/iptables.rules saving then restarting but the rule comes back even after reboot.

share|improve this question
add comment

1 Answer 1

Have you try doing this iptables -D PREROUTING -d 95.211.213.149/32 -i venet0 -p tcp -m tcp --dport 443 -j REDIRECT --to-ports 1194 then iptables-save or sudo sh -c "iptables-save > /etc/iptables.rules"

Also do you have any program that is like ConfigServer Firewall (csf) installed that is managing your firewall?

If you are new to iptables I would read up on Iptables here.

share|improve this answer
    
Thanks I did that and it worked but funny thing is I could have sworn i tired it I guess i did not have the right option in there. Issue is resolved now –  user219937 Nov 27 '13 at 20:41
    
@user219937 Glad to hear the issue is resolved! :) –  K2Chris1983 Nov 27 '13 at 21:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.