Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04. It got installed and at the end of installation it asked me to restart. I clicked the restart button simultaneously i removed the USB flash drive which I used for installation.

After restarting it is directly switching to windows and not to asking me for the choice. I thought that Ubuntu is lost and i tried one more time. While installing second time during the process of installation it asked me options like to replace Ubuntu or windows or Ubuntu or both. So i confirmed that Ubuntu is there inside the laptop.

Please tell me how to access to my Ubuntu which is there in my laptop. My laptop model G580.

Thanks in advance.

share|improve this question
    
Do you See the GRUB menu at all? –  samgabbay Nov 27 '13 at 16:37
1  
see this askubuntu.com/questions/382242/… –  Avinash Raj Nov 27 '13 at 16:41

1 Answer 1

For some reason, when installing Ubuntu from a USB, the default GRUB destination chosen by the installer (on the partitioning page) is /dev/sdb (the USB disk). This happens to me every single time.

That means that you haven't actually installed GRUB to your hard disk, eventually ending up with no choice but windows every time you boot. You had to switch the destination to /dev/sda (which is your primary hard disk).

Now, you can try re-installing Ubuntu and choose to install GRUB on /dev/sda, or repair GRUB by referring to the link that Avinash Raj mentioned in a comment on your question.

Edit: Check this link too. It has instructions on how to install GRUB from a Live CD/USB (thanks to samgabbay).

Regards.

share|improve this answer
1  
I Recommend they Simply CHeck this out: help.ubuntu.com/community/Grub2/Installing –  samgabbay Nov 27 '13 at 17:25
    
Yes, that screen shot is really helpful! –  errikos Nov 27 '13 at 17:26
    
From My Answer? If yes, Should i post my answer? –  samgabbay Nov 27 '13 at 17:27
    
Good. Im Happy you fixed it –  samgabbay Nov 27 '13 at 17:28
1  
I hadn't copied the link to your profile, so I had to edit afterwards. –  errikos Nov 27 '13 at 17:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.