Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to get the gstreamer1.0 demos to work on 12.04, python 3.2.3 and am getting the following

(precise)raymond@localhost:~/workspace/nexense$ python video-player-1.0.py    \
ERROR:root:Could not find any typelib for GstVideo
Traceback (most recent call last):
File "video-player-1.0.py", line 11, in <module     from gi.repository import GdkX11, GstVideo
ImportError: cannot import name GstVideo

AFAIK I have installed the recommended packages from the gstreamer PPA

sudo add-apt-repository ppa:gstreamer-developers/ppa

sudo apt-get install gstreamer1.0*

and I then try to add in the packages explicitly named on the NovaCut porting guide, the closest thing to a canonical source I could locate:

sudo apt-get install python-gi python3-gi \
gstreamer1.0-tools \
gir1.2-gstreamer-1.0 \
gir1.2-gst-plugins-base-1.0 \
gstreamer1.0-plugins-good \
gstreamer1.0-plugins-ugly \
gstreamer1.0-plugins-bad \
gstreamer1.0-libav

which actually fails to find some of the listed packages

E: Unable to locate package gstreamer1.0-tools
E: Couldn't find any package by regex 'gstreamer1.0-tools'
E: Unable to locate package gir1.2-gstreamer-1.0
E: Couldn't find any package by regex 'gir1.2-gstreamer-1.0'
E: Unable to locate package gir1.2-gst-plugins-base-1.0
E: Couldn't find any package by regex 'gir1.2-gst-plugins-base-1.0'
E: Unable to locate package gstreamer1.0-libav
E: Couldn't find any package by regex 'gstreamer1.0-libav'

Does anyone have gstreamer 1.0/python/12.04 working?

share|improve this question
    
I installed GStreamer1.0 on Xubuntu 12.04 for development last week and everything works. Did you run sudo apt-get update after adding the PPA? Then try to locate the packages again. –  Timo Nov 28 '13 at 11:19
    
Yes @Timo I did but I just did it again to confirm. No errors on the add-repos or the update. Same error trying to run the demo file video-player-1.0.py –  raygeeknyc Dec 1 '13 at 3:49
    
@Timo - You inspired me and I decided to try it on another machine running 12.04 and it worked - I realized the difference is architecture - it worked on an X86 and failed to install on an ARM7 machine. [I suppose] the packages are available per-arch. I'll try compiling it from source. –  raygeeknyc Dec 1 '13 at 22:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.