Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to Ubuntu 11.04 and my system is setup for Dual Monitors. When I logged in I noticed my desktop icons looks very strange, as if they were being stretched. I could not click on them either. I finally discovered that if I turn off my second monitor that the desktop displays correctly and I can click on the icons again. When I turn on the second monitor, Ubuntu is stretching the desktop across both monitors. The icons are not placed in the correct location and therefore I am not able to click on them.

Is there any way to correct this?

Thank you for your time.

share|improve this question

closed as too localized by jrg, RolandiXor, Marco Ceppi Dec 15 '11 at 8:02

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  jrg Dec 14 '11 at 18:43

2 Answers 2

I have had the exact same problem after a 11.04 upgrade myself. I've found that it seems to be related to Compiz. If I disable the OpenGL Compiz plugin the icons and desktop picture display correctly, but of course I'm now missing all the OpenGL effects. Just in case it's relevant, I'm using the open source Radeon driver (with an ATI Radeon X1800).

share|improve this answer

As Mirumu mentioned, this is a bug with Open Source ATI drivers when using Compiz. You haven't mentioned whether that is what you use, but I can almost be sure that is the problem. I would suggest using Unity 2D.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.