Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Problem: My audio is not working. I'm getting that "Dummy Output" in the sound settings. I've been scouring the web, but nothing I try is working. I've tried

sudo alsa force-reload

sudo apt-get remove --purge alsa-utils

sudo apt-get install alsa-utils

I've tried about every single little thing, and it's driving me crazy.

Ubuntu dist: Saucy Salamander (13.10, running GNOME-3 Desktop) Results of lspci:

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 7 Series Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)
03:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0a)

(wasn't quite sure how much you guys needed)
For some reason, I don't have a .asoundrc file or /etc/asoundrc.conf file. I can't get into alsamixer either. I've uninstalled, reinstalled, uninstalled, and reinstalled alsa-base, alsa-utils, pulseaudio, and even Wine.
I don't know what else to do at this point. Can you guys help me?

EDIT: sudo alsa force-reload returns

 Unloading ALSA sound driver modules: (none loaded).
Loading ALSA sound driver modules: (none to reload).
Do I have to reinstall Ubuntu?

share|improve this question
    
go to home , press Ctrl+h and then there you will find .asoundrc and its used from /usr/share/alsa/alsa.conf and possibly you might have it at /etc/asound.conf. –  Sushantp606 Nov 27 '13 at 2:01
    
Umm.. that's the problem. When I press Ctrl+H, there is no .asoundrc file. @Sushantp606 –  YungDaVinci Nov 27 '13 at 2:16
    
try to edit speech dispatcher once. –  Sushantp606 Nov 27 '13 at 2:17
    
that means alsa-base is not installed, to make sure use aptitude search alsa-base .. Open Synaptic and click on reload. When it's done running see if it shows any broken packages or upgrades. btw which kernel are you using?? –  Sushantp606 Nov 27 '13 at 2:34

2 Answers 2

up vote 0 down vote accepted

After searching, I have found a simple answer. Just execute

killall pulseaudio

Your speakers should work fine now. To ensure this, test the sound stack in System Settings > Sound > Test Sound (Speaker test, Not Digital Output (S/PDIF) test)

The only problem with your issue is there is no driver found for your audio for that then Try to reinstall pulse audio and Alsa, open terminal and enter the following commands-

sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio
sudo alsa force-reload

even Upgrading your sound drivers may fix the nosound issue , for that use the following commands -

 sudo add-apt-repository ppa:ubuntu-audio-dev
 sudo apt-get update
sudo apt-get dist-upgrade

the final try from me is to make some changes in speech-dispather by-

sudo gedit /etc/default/speech-dispatcher

and change

RUN=yes 

to

RUN=no

hope these workarounds will solve your issue, before testing make sure to restart once after doing any of the method.

share|improve this answer
    
killall pulseaudio just made my mouse disappear. The other things didn't do anything. –  YungDaVinci Nov 27 '13 at 2:18
    
In speech-dispatcher, it was already set to RUN=no. –  YungDaVinci Nov 27 '13 at 2:23
    
everything is done from my side, sorry I could not figure it out, backup your data and re-install it , and for the last time force reload by sudo alsa force-reload, and then restart . i was having the same issue once on my dell inspiron and just a restart worked out. –  Sushantp606 Nov 27 '13 at 2:27
    
if nothing works downgrade your kernel once , thats the last hope i know , if it works well and good otherwise you need to re-install. –  Sushantp606 Nov 27 '13 at 2:52
1  
I booted Xubuntu from my flash drive. I think it's that I don't have a soundcard (or they aren't being recognized). Thanks for your help though –  YungDaVinci Nov 27 '13 at 3:31

I solved this problem:

  1. sudo apt-get purge alsa-driver-linuxant
  2. https://help.ubuntu.com/community/SoundTroubleshootingProcedure
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.