Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having a problem while playing .mkv files. Every time I play a .mkv file, the audio can be heard but video cannot be seen. The only way to see the video if I actually right click on it or put a window in front of it and it displays one part of the video but not all.

PHOTO OF PROBLEM

The link of the picture above basically describes what I am saying. While I was trying to take the screenshot, the window for the screenshot disappeared and displayed part of the video. I hope someone could help me on this. Thank you!

EDIT: I was running Unity 2D when I have the problem but when I run Unity 3D, it works. So I need to make this work on 2D. Please help.

share|improve this question
    
Does something like "mplayer -vo xv -fs -zoom filename.mkv" from the terminal help? -vo xv selects a "default video driver" and the rest fullscreens your video. You might also want to man mplayer for subtitle and audio/video track switches :P –  Syzygy Apr 30 '11 at 2:29
    
no...i didint try doing that...but it looks kinda confusing for me of what u said... im still 15 lmfao –  Kevin Maghuyop Apr 30 '11 at 3:15
    
Did you try to logout and login using gnome classic (no effects) and then try to play the movie with VLC? –  Luis Alvarado Apr 30 '11 at 18:35
    
it works in there.....It works everywhere besides Unity 3D –  Kevin Maghuyop Apr 30 '11 at 19:03
    
maybe your hardware isn't good enough... –  Alvar Oct 14 '11 at 19:33

2 Answers 2

Download VLC. Does .mkvs out-of-the-box flawlessly.

share|improve this answer
    
it happens on VLC also –  Kevin Maghuyop Apr 30 '11 at 1:24
    
Hmm... I wonder if this is a graphics driver issue. Are you using the Linux kernel driver or a proprietary one? –  boehj Apr 30 '11 at 2:01
1  
i think proprietary......lol...i have to ATI catalyst software –  Kevin Maghuyop Apr 30 '11 at 3:13
1  
OK, that means it's a proprietary one. In my experience proprietary graphics drivers work better than the ones in the kernel. Nonetheless, you may have some luck by disabling the proprietary driver for testing purposes. See if that solves your problem. The option to switch it off is under System > Administration (from memory). –  boehj Apr 30 '11 at 3:21
    
i have 11.04 so i dont know –  Kevin Maghuyop Apr 30 '11 at 3:29

i would try smplayer if i were you

if smplayer didn't work i would remove the driver like boehj said and restart. then i would install, from the same place (additional drivers), the "experimental" drivers (second one in the list - if it is there before you remove the ati drivers just click activate on it without the "remove-restart-install" part) and restart again

(that's a strange bug you got there, by the way...)

(my answer is by no means a "good" one, it is just the only one i can think of right now, sorry)

(edit : by the way, there is no need going to the classic desktop to do that, just write whatever you search for in the search part of dash and it will pop up. easier than navigating to it..)

share|improve this answer
    
This actually work.....but it has the same problem i have up there...but i am still able to enjoy the movie....thank you!!! –  Kevin Maghuyop May 3 '11 at 1:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.