Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

A few days ago, I upgraded my Windows 8 Lenovo U410 ideapad to Windows 8.1, and it proved to be a terrible mistake. It seems like the only visible change that it has made is adding the start button. Meanwhile, it disabled my audio, and I had to go and reinstall drivers from Lenovo's website. Even worse, it is completely blocking me from running Ubuntu in any way possible.

I have my hard disk partitioned into three main partitions: 100GB for Windows (in NTFS); 100GB for Ubuntu (in ext4...I think); and a 550GB storage drive (in NTFS). Then on start up, the Ubuntu GRUB screen (this one) would come up and I would be able to choose between booting into Ubuntu and Windows 8. However, now after the update, I boot straight into Windows 8.1, and cannot access the Ubuntu file system.

This wouldn't be that big of a problem, if it wasn't for the fact that three almost-finished Honors English papers are on there, and I NEED them. So first I tried booting into the Ubuntu partition from the bios, which didn't work, and neither did trying to boot into it from the "Use a Device" menu in the Windows "Advanced Startup" menu. Next, I tried moving the Ubuntu partition to the first spot in the boot sequence, and starting up my computer again. When that had no effect, I created an Ubuntu USB drive, and went through all the same steps (this is what the answers to questions similar to mine recommend). Again, no result. I've also noticed that even after changing the boot sequence in the BIOS, Windows Boot Manager forces itself back to the front.

I'm at a loss for what to do, and I really need those English papers, so any help is MUCH appreciated. Thank you for reading this far, and thanks in advance for any advice.

share|improve this question

marked as duplicate by Rod Smith, guntbert, Braiam, karel, Mitch Nov 27 '13 at 3:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

I think Windows has re-written your main disk's first sectors, to put its own boot loader back on. You need to reinstall GRUB on this disk, by running these commands from a Ubuntu live CD :

Adapt! Select your main drive. Use fdisk -l as root to find out its device file.

grub-install --recheck /dev/sda
grub-mkconfig -o /boot/grub/grub.cfg
update-grub # May be useless.

If you need a way to access your BIOS (to boot on the Live CD for instance), have a look here maybe :

Your main challenge is to reach a Ubuntu Live install. Windows messed up the boot procedure, as it always does. Try not to be messy : Windows got control of your boot, you don't want to piss it off.

By the way... Being unable to reach Ubuntu doesn't mean you can't reach its partitions from Windows. However, you need to assign them a letter and access path using the Windows disk management utility.

share|improve this answer
    
A computer that ships with Windows 8 or 8.1 almost certainly doesn't use a BIOS-mode boot loader, meaning that it doesn't read boot code from the MBR. Instead, what's probably happened is that Windows has set its boot loader as the default in the firmware's NVRAM. This produces similar symptoms, but the solution is different -- see this question and answer for details. –  Rod Smith Nov 26 '13 at 19:19
    
My bad. I forgot the recent evolutions on Microsoft "how to get rid of curious computer scientists". Anyway, the solution is still to get access to a Ubuntu Live, I believe my links won't be useless. Thanks for the reminder ;) –  John WH Smith Nov 26 '13 at 19:21
    
Actually, it can (probably) be fixed from Windows, as my answer to the linked-to question details. This fix is sometimes more reliable than fixes involving re-installing GRUB from Linux, but that depends on the firmware and what Windows does. (The latter doesn't seem entirely consistent, judging by conflicting reports I've seen online.) –  Rod Smith Nov 26 '13 at 19:25
1  
@RodSmith the 'bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi' solution doesn't work. When I run it in the Windows command prompt, I get, "The boot configuration data store could not be opened. Access is denied." This confuses me though, because I am admin. –  user219637 Nov 27 '13 at 20:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.