Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using I7 Dell laptop. I installed Ubuntu 13.04 along with windows 8. When I use Ubuntu, I feel fan speed is high, which I don't see when using in windows 8.

I installed tlp package but that did not help either.

--- TLP 0.4 --------------------------------------------

+++ Temperatures
CPU temp               =    49 [°C]
Fan speed              = (not available)

I m not sure why Fan speed is not altered.

I tried to install Graphics driver from https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=13815 but after the hell happened. I lost my unity and all the graphics gone then it took me hours to restore the system with old option.

Do I not have any other option for installing graphics driver or any other remedy like installing Ubuntu 13.10?

Output of lspci command is:

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Chelsea LP [Radeon HD 7730M]
share|improve this question
    
result of lspci cant be that short ..its just two lines , am getting 22 lines.. –  Sushantp606 Nov 27 '13 at 1:24
    
maybe you can found sth from this. the bumblebee project: wiki.ubuntu.com/Bumblebee –  roc lee Nov 27 '13 at 1:31
    
@sushantp606 : I grepped only related to VGA –  Kirubakaran Sujanaranjan Nov 27 '13 at 2:04
    
have you tried mesa?? –  Sushantp606 Nov 27 '13 at 2:09
add comment

2 Answers 2

Most of times it could be about your graphic card gets warm and because your graphic card is integrated into your cpu the system thinks that cpu gets warm

install mesa-utils and mesa-utils-extras and reboot , for installing use the following command-

sudo apt-get install mesa-utils mesa-utils-extra  

it will work for Intel Graphic Cards

If you are having NVIDIA graphic card then use bumblebee because mesa and NVIDIA will conflict with each other for sure.. to install bumblebee use-

sudo add-apt-repository ppa:bumblebee/testing

then for 12.04 and 13.04 use-

sudo apt-get install bumblebee bumblebee-nvidia virtualgl linux-headers-generic 

otherwise for 13.10 use-

sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generi

( for newcomes: the $ before this command is just an indicator that tells this command should be entered in a standard user command shell. if you want to use it just press <ctrl>+<alt>+<t> and copy-paste without this dollar mark )

If that doesnt work, try to

  1. Cleaning your laptop- As might be its because of just that, stopping fan from running properly.

  2. Update bios - After updating it can perform good operations like increasing compatibility .That solved my issue.

  3. Update Kernel

hope the very first suggestion will resolve your problem.

share|improve this answer
add comment

It could be that you have an Intel CPU with integrated GPU and a discrete NVidia GPU. In Windows graphics driver optimizes the usage of GPU switching between NVidia and Intel GPUs depending on the load.

If this is the case, install bumblebee package to disable by default NVidia card. On my laptop this saves some battery and decreases fan noise with system temperature

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.