Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

UPDATE: I need this laptop, and this problem makes it pretty unusable, so I ended up having to restore from a backup. If it happens again I'd be able to test any suggestions, but otherwise I may not be of much use in confirming answers.

I booted my 13.10 laptop today to find that I am now unable to login.

I see the lightdm login screen and can type my password. It gets accepted then I see a blank background and a mouse cursor which I can move and nothing else happens.

I am able to login to the terminal ctrl-alt-F1 and see that there is a init process which is using 90% CPU. Killing this pid brings me back to the login screen.

Some other things I've found possibly related:

  1. creating a new user or logging into guest account produces same result.
  2. install gnome-sessions-fallback and try logging into that produces the same result.
  3. .xsession-errors contains the line "init: Temporary process spawn error: Bad file descriptor"
  4. doing lsof on the init pid shows some info:

    lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /rus/user/1000/gvfs
          output information may be incomplete
    

    Also, I sometimes see mention of a my-weather-indicator crash.log file. I tried uninstall my-weather-indicator (didn't help)

    There are a lot of pipe files which pop up periodically with errors like "(readlink: no such file or directory)" with a path to /proc/####/fd/### pattern

  5. strace on the process informs me that it is repeatedly trying to open the file /dev/ptmx, and open a pipe, then it closes the three file descriptors.

I can't recall exactly what I did yesterday that may have done this. I booted the laptop at home and did some compiles at the end the compile completed, but the init process was at 100%. I didn't think anything of it and powered off thinking it would be better after a reboot in the morning.

Anyway, maybe someone can help. I don't even know where to go about reporting this bug. I'd also like to avoid reinstalling, but at this point it may be faster than debugging this.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.