Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to install my graphics driver it shows that-

"one or more tools requied for installation cannot be found on the system. install the required tools before installing the fglrx driver. optionaly, run the installer without --force to install the tools. Forcing install will disable the AMD hardaware acceleration and may make your syatem unstable. not recommended. see /usr/share/ati/fglrx-install.log for more details."

I installed fglrx and tried again, but it did not work. And a system problem detected during installing the fglrx.

It's very important to install my graphics driver for my job!

The graphics driver also does not appear in the additional driver.

What can I do??


/usr/share/ati/fglrx-install.log shows that

Check if system has the tools required for installation. 
fglrx installation requires that the system have kernel headers. 
/lib/modules/3.8.0-33-generic/build/include/linux/version.h cannot be found on this system. 
One or more tools required for installation cannot be found on the system. 
Install the required tools before installing the fglrx driver. 
Optionally, run the installer with --force option to install without the tools. 
Forcing install will disable AMD hardware acceleration and may make your system unstable. 
Not recommended.
share|improve this question
    
How about you show us the /usr/share/ati/fglrx-install.log log? –  Braiam Nov 26 '13 at 13:52
1  
Edit the question... DO NOT USE COMMENTS –  Braiam Nov 26 '13 at 14:08
    
You must provide more information in order to get help. Please open a terminal (CTRL+ALT+T) and issue these commands one by one lsb_release -rcd;uname -rm , lspci -nnk | grep -iA2 vga , X -version . Then edit your question and add the additional info. –  NikTh Nov 26 '13 at 14:16
    
@anik edit your question! also, show us the content of the log file. Repeat the following command lspci -nnk | grep -A5 VGA. –  Braiam Nov 26 '13 at 15:15
1  
@anik - comments SHOULD NOT be used to respond with information. I have deleted those comments. Please edit your question with any replies. thanks. –  fossfreedom Nov 26 '13 at 15:18

2 Answers 2

You need your kernel headers to install fglrx. To install them is easy:

sudo apt-get install linux-generic

now reboot your system. If you do not reboot the installation will continue failing.


Be aware that most of the time the proprietary drivers are not necessary, unless you have a very recent/new graphic card.

share|improve this answer
    
linux-headers-<KERNEL-VERSION> package should be installed by default. Actually, it is installed by default. I guess that the problem resides on Xorg version and graphics card model. But until OP gives us more information, I cannot be sure. –  NikTh Nov 26 '13 at 17:33
1  
@NikTh I'm taking /lib/modules/3.8.0-33-generic/build/include/linux/version.h not found message as parting point. The package that keeps the headers installed and updated is linux-headers. I'm guessing that somehow he managed to prevent the headers from being updated/installed. My method do both, install the latest image and headers. If you want to check do aptitude why linux-headers-$(uname -r) to see the real reason why the headers are installed ;). –  Braiam Nov 26 '13 at 17:38

after installing kernel headers you should also do sudo apt-get install gcc it worked for me well

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.