Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I re-installed mono-runtime due to this error and it is solved.
But now I want to uninstall it (but in Ubuntu 13.10). So this is what happens:

hogar@hogar-desktop:~$ sudo apt-get purge mono-runtime
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk2.0-cil : Depends: libmono-cairo4.0-cil (>= 2.10.1) but it is not going to be installed
                 Depends: libmono-system-drawing4.0-cil (>= 1.0) but it is not going to be installed
 libmono-corlib4.0-cil : Depends: mono-runtime (>= 2.10.8.1) but it is not going to be installed
                         Depends: mono-runtime (< 2.10.8.2) but it is not going to be installed
                         Recommends: libmono-i18n-west4.0-cil but it is not going to be installed
 libmono-system-web-services4.0-cil : Depends: libmono-system-configuration4.0-cil (>= 1.0) but it is not going to be installed
                                      Depends: libmono-system-enterpriseservices4.0-cil (>= 1.0) but it is not going to be installed
                                      Depends: libmono-system-web4.0-cil (>= 2.10.3) but it is not going to be installed
 libmono-system4.0-cil : Depends: libmono-security4.0-cil (>= 2.10.1) but it is not going to be installed
                         Depends: libmono-system-configuration4.0-cil (>= 1.0) but it is not going to be installed
                         Depends: mono-runtime (>= 2.10.8.1) but it is not going to be installed
                         Depends: mono-runtime (< 2.10.8.2) but it is not going to be installed
 monodoc-manual : Depends: monodoc-browser but it is not going to be installed or
                           monodoc-http but it is not going to be installed or
                           monodoc-viewer
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I looked at this very popular post but in this case I'm not installing a package. So not very sure

Any idea?


Additional info:

  • My /var/log/dist-upgrade/apt.log file is empty.
  • The command dpkg --get-selections | grep hold returns nothing
share|improve this question
    
How did you install mono? I think it isn't present by default on 13.10. –  user25656 Nov 26 '13 at 6:15
    
Can't remember, but most probably was sudo apt-get install mono-runtime –  Lucio Nov 26 '13 at 6:27
    
Possible answer? –  Manish Sinha Nov 26 '13 at 7:23
    
No and no. That answer didn't solve it, and I am not holding packages. –  Lucio Nov 26 '13 at 23:14
    
even i dont have "/var/log/dist-upgrade/apt.log", might be this error is prompting that after removing mono the other stuffs depending on it wont work. –  Sushantp606 Dec 1 '13 at 4:22

1 Answer 1

up vote 4 down vote accepted
+50

arg! It's just apt-get being silly, you need aptitude to solve problems:

sudo apt-get install aptitude
sudo aptitude -fy remove mono-runtime

That should deal with it.


A resume of the problematics packages:

  • libgtk2.0-cil this is really a mono dependency. Unless you use Banshee you won't need it.

    CLI binding for the GTK+ toolkit 2.12

    This package provides the atk-sharp, gdk-sharp, gtk-dotnet, gtk-sharp and pango-sharp assemblies that allow CLI (.NET) programs to use the GTK+ user interface toolkit 2.12, ATK, Pango, GTK.NET and GDK.

    GTK# 2.10 is a CLI (.NET) language binding for the GTK+ 2.10 toolkit

    This package contains the GTK# assemblies

  • libmono*

    Just some mono dependencies, and you want to uninstall it.


All in all, all the packages are easily removable, and I'm actually thinking that they didn't get installed in the first place. You can check using:

dpkg -l libgtk2.0-cil libmono-corlib4.0-cil libmono-system-web-services4.0-cil libmono-system4.0-cil monodoc-manual | grep -v 'ii '

If no package shows, then you can be sure that none were installed in first place and is just apt-get doing your life impossible.

share|improve this answer
    
This is what I get entering your last command: paste.ubuntu.com/6521653 I have no idea of what does it mean. Should I use aptitude anyway? –  Lucio Dec 4 '13 at 20:29
    
aptitude did the job. It has uninstalled every depends package. For example: pinta, monodevelop among others. TL;DR worked as expected. –  Lucio Dec 4 '13 at 20:42
    
@Lucio you need aptitude to solve apt weirdness. –  Braiam Dec 4 '13 at 20:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.