Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I added this script to my startup programs to change my touchpad settings on startup:

synclient TapButton2=2 TapButton3=3

But this settings don't stay this way after startup.

I changed my script to watch the results:

synclient TapButton2=2 TapButton3=3
synclient | grep TapButton > $HOME/tmp/touchpad.txt

Results were confusing, touchpad still didn't work the way I want:

$ cat ~/tmp/touchpad.txt
TapButton1              = 1
TapButton2              = 2
TapButton3              = 3

But when I ran synclient | grep TapButton in gnome-terminal after startup the output was:

$ synclient | grep TapButton
TapButton1              = 1
TapButton2              = 3
TapButton3              = 0

I tried adding delays (sleep 10s) to my script before and/or after every line, but this didn't help too.

Therefore I assume that there is another program, script or daemon that changes touchpad settings, but I couldn't find which one.

Two questions:

  • Which program, script or daemon can change touchpad settings?
  • Is there another way to permanently change your touchpad settings? Maybe adding such script to startup is not supposed to be working.

Update

I tried putting

Section "InputClass"
    Identifier "touchpad my settings"
    MatchIsTouchpad "on"
    MatchOS "Linux"
    MatchDevicePath "/dev/input/mouse*"
    Option "TapButton1" "1"
    Option "TapButton2" "2"
    Option "TapButton3" "3"
    Option "PalmDetect" "on"
EndSection

into file /usr/share/X11/xorg.conf.d/99-my.conf. It didn't help as well.

share|improve this question

2 Answers 2

I've got a simple solution...

Just press the windows key and type 'startup'. You will see 'Startup applications'

  • click this and then click [ADD]
  • give it a name (like mousetap2)
  • enter the command in the box... i.e.

    synclient TapButton2=2 TapButton3=3
    

and that's it...

It will run on startup and configure the trackpad all without pissing about with configuration files.

share|improve this answer
    
This answer is the same as another one. –  Andrey Rybak Feb 28 at 19:56
up vote 0 down vote accepted

Very bad, but working solution to my problem:

Adding this script to startup programs:

#!/bin/bash

while true;
do
    synclient TapButton2=2 TapButton3=3
    synclient | grep Tap > $HOME/tmp/touchpad.txt
    sleep 20s
done
share|improve this answer
    
Sympathy: I've been fighting with my touchpads for years on and off. Where did you put your synclient statement? I put mine in KDE's Autostart folder so it gets set when the desktop starts. (gnome has an almost identical feature.) I think that works better than putting it in $HOME/.profile. If you put it in your init scripts somewhere, then something in the desktop could easily override it later. If you haven't used it yet, gsynaptics is handy for examining and fixing things during testing. –  Joe Nov 28 '13 at 12:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.