Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running an upgrade from Maverick to Natty from a mounted 'alternate' ISO, but it's current status is "Fetching file 1444 of 1703 at 55.1 kB/s". I'm pretty sure it's trying to use the network for the "Getting new packages" phase. How can I make sure it uses only the ISO, and not the network? Disconnecting the network (or keeping it disconnected the entire time) just results in stalling (waiting, not freezing) during the "Getting new packages" phase.

I've followed the instructions on the Ubuntu Wiki for upgrading using the Alternate CD ISO mounted as a drive. Also, I selected "No" to the question about updating packages during the upgrade.

If this is a bug, please give a link with the bug number or tell me that I should file a bug.

share|improve this question
    
In case anyone is tempted to ask, yes, I verified that the ISO file didn't have errors; I used Transmission to download and verify it. –  Firefeather Apr 29 '11 at 20:35
    
I tried running gksu /media/cdrom/cdromupgrade from the terminal, and it outputs WARNING: Failed to read mirror file at the beginning of the "Setting new software channels" step. Perhaps that has something to do with it? –  Firefeather Apr 29 '11 at 22:45
    
I just had the same problem - said "no" to the download question, and it still tries to download. I just think about pulling the network cable, but when you say this does not help ... –  Paŭlo Ebermann Apr 30 '11 at 15:04
    
This bug 353825 describes the same symptom. I'm not sure it has the same cause here. –  Paŭlo Ebermann Apr 30 '11 at 15:16
    
@Paulo: Yeah, there weren't any packages in a broken state. –  Firefeather May 1 '11 at 20:28
show 2 more comments

4 Answers

Using the Alternative CD, and not unplugging the Ethernet (before) boot, does NOT behave the same as answering: NO.

Have you tried, with the network cable umplugged?

share|improve this answer
    
Yes, I have tried with the network cable unplugged. –  Firefeather Dec 21 '11 at 20:06
    
This has solved issue for me (in past), but I unplugged Ethernet cable before boot .. –  david6 Dec 21 '11 at 20:21
add comment

I also had this problem. My solution was to uncheck all software repositories, then the upgrade from cd worked.

share|improve this answer
add comment

Following the upgrade instructions on the Ubuntu Wiki:

Burn the ISO to a CD and insert it in your computer OR mount the ISO using:

sudo mount -o loop ubuntu-11.04-alternate-amd64.iso /media/cdrom

When done, run the upgrade application from the CD:

gksu /media/cdrom/cdromupgrade

Follow the instructions, when askes whether you want to download updates from the internet, choose No.

share|improve this answer
    
:) That's exactly what I did: see the second paragraph of my question. –  Firefeather Apr 29 '11 at 21:03
1  
@Firefeather: have you got the right ISO? I almost messed my system up by using an ubuntu ISO instead of a kubuntu one for my Kubuntu system. –  Lekensteyn Apr 29 '11 at 21:09
    
Great troubleshooting question, but I am using ubuntu-11.04-alternate-i386.iso to upgrade Ubuntu 10.10 32-bit. Shouldn't be any problems there. –  Firefeather Apr 29 '11 at 21:28
add comment

The alternate cd does not have everything on it. I recently did this using the dvd image and it seemed to only download one or two things ( I didn't answer no to the question ). Maybe you have a bunch of packages installed that are not on the alternate cd so it has no choice but to download them?

share|improve this answer
    
I would think that if a package wasn't in the default install (thus on the alternate CD), one of two things would happen: (1) The upgrade breaks the package's dependencies, so the upgrade program sets it to be removed and notifies you of that decision; or (2) The upgrade doesn't affect the package's dependencies, and answering "No" makes the "repository" on the CD the only one that the upgrade program's aware of, so, not seeing anything affecting that package, it leaves the package alone. Do you know of something that says anything to the contrary? –  Firefeather May 6 '11 at 19:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.