Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Sony Vaio Pro 13, which came pre-installed with Windows 8 and the Vaio Care/Rescue Utility. My goal was to make it dual-bootable to Ubuntu 12.04 as well. As it turns out, the Ubuntu install worked, but it is not bootable, and after a few runs of boot-repair, it does not boot to Windows 8 and I cannot access the recovery partition that is built into the laptop. The only thing I can do is boot from my LiveUSB (with try ubuntu) The last boot-repair gave me this : http://paste.ubuntu.com/6464375 and after I tried to recover Windows this http://paste.ubuntu.com/6469950

share|improve this question

2 Answers 2

Your problem is that boot-repair did not update GRUB2 correctly. Luckily, there is a very easy fix for this. Here's what you can do:

  1. Boot to Ubuntu.
  2. Press Ctrl+Alt+T To start a Terminal emulator.
  3. Type sudo update-grub and press Enter.
  4. Once the command is finished, reboot.

You should now see Windows 8 as an option in your boot menu. Good luck and have fun with Ubuntu!

share|improve this answer
    
Unfortunately incorrect answer, as Boot-Repair already did an update-grub (see line 931 of Hugo's log paste.ubuntu.com/6464375). Line 938 you can see that there is already a Windows 8 (loader) entry in the GRUB menu. –  LovinBuntu Nov 24 '13 at 21:16
    
I've had this same problem. boot-repair often says it runs update-grub, but often that causes problems. Doing it from Ubuntu itself fixes that (I know from experience). –  Dillmo Nov 24 '13 at 22:04
    
Never seen any report about such issue :) If you can reproduce, please could you create a bug report HERE ? (please indicate the Boot-Repair log, and the output of update-grub) –  LovinBuntu Nov 25 '13 at 18:16

Run Boot-Repair again, but this time answer No to the question Do you want to activate [Backup and rename Windows EFI files]. Then reboot, you should be able to access both Windows and Ubuntu via the BIOS (indeed UEFI firmware).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.