Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Performance being really choppy with ATI drivers

I just upgraded my main machine to Natty. I have an ATI 2600 with the proprietary ATI driver. It worked fine with Maverick on both 3D games and the Compiz desktop.

Now games still work, but merely moving windows laggs really annoyingly. Is there some way to fix this?

share|improve this question

marked as duplicate by Marco Ceppi Jun 5 '11 at 19:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

up vote 4 down vote accepted

Install Compiz Config Settings Manager and launch it. You need to follow these steps:

  1. Go to Composite plugin and disable 'Detect Refresh Rate'
  2. In the option below, enter your monitor refresh rate. Mine is 60.
  3. Now go to OpenGL Plugin and disable 'Sync to Vblank'
  4. Logout and come back.
share|improve this answer
Awesome! I did not even need to log out. You saved my day! – Martin Ueding Apr 29 '11 at 19:46

Try this out:

  1. Install compiz-manager by sudo apt-get install compizconfig-settings-manager
  2. Go to "CompizConfig Settings Manager"
  3. In OpenGL pluging deselect "Sync to VBlank"
share|improve this answer

I had same problem, but, however, in my case adjusting compiz settings didn't help a lot.

I also had ATI drivers installed. Then I noticed ATI had JUST released new ones, which are said to have much better supprot for the latest X and Unity. However, ATI released them too late, and they failed to get into Ubuntu repositories.

What I reccoment you is to uninstall the ATI driver (fglrx) Ubuntu installed for you, and get the newest one from the ATI's site:

In my case this provided incredible improvement of overall performance. I hope it will help you too!

share|improve this answer

Thank you for this answer, but to be honest, I already did this. I am using catalyst version 11.3 (Release Date 4/27/2011) witch is, as fare as I know the latest release. To use this driver instead of those witch are shipped with Ubuntu was my first guess, but it did't work out. Thank you anyway!

share|improve this answer

I have the same issue, but it works a bit better with OpenGL plugin select "Sync to VBlank". It is usable but lags and before upgrading it does not. So it seems to be a bug. That not every thing works well is also shown by the fact that compiz becomes unusable if I set the cube transparent. Than it lags like hell. I hope some expert will find a solution soon. Maybe it has something to do with the ATI-Driver?

Must be a Compiz bug: There is a bug report for this problem, please vote! Compiz effects slow and laggy on Natty with ATI card

share|improve this answer
Before upgrade, you used No effects or Medium effects? I think with Maximum effect it lags on 10.10 too... And in Unity default is Maximum. So you can use Classic Ubuntu or maybe Unity2D – Extender May 1 '11 at 5:19
I used maximum effects before upgrading with out any problems. Even my Netbook with atom an intel graphik device does maximum effects with out lags in 10.10. Wobbeling windows as well as desktop cube with transparency.But after upgrading the same problem occurs with Unity and »Ubuntu Classic«. It seems to be an serious Compiz bug. – user5950 May 1 '11 at 15:32
For Intel graphics, I would recommend x-swat repository (with newest version of xorg and drivers) – Extender May 1 '11 at 16:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.