Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Oracle Database 12c on an Ubuntu 12.04. I followed this tutorial and haven't done much more than that.

After the installation I tried to connect sqldeveloper to the database, something I already did with 11g & Windows 7 and 11g & Ubuntu. Anyway so I'm getting this error:

Status: Failure -Test failed: IO Error: The Network Adapter could not establish the connection

I tried executing the netac command but it didn't work as a command I had to execute the bin, and the output was:

oracle@abdou-pc:/oracle/base/dbhome_1/bin$ ./netca

Oracle Net Services Configuration:
No protocol specified
No protocol specified
Error: null

here is the log: http://pastebin.com/ir4ecG3u

I thought this may also be of use:

root@abdou-pc:/home/abdou# oraenv
ORACLE_SID = [root] ?
ORACLE_HOME = [/home/oracle] ?
ORACLE_BASE environment variable is not being set since this
information is not available for the current user ID root.
You can set ORACLE_BASE manually if it is required.
/usr/local/bin/oraenv: 223: [: unexpected operator

My Oracle is installed in /oracle/base/dbhome_1

I don't know what other info I should post, and I don't wanna flood you people, so I'm here and I can post any info you need on demand.

It seems to me that my Oracle db isn't even launched, and neither are the listeners, and there might be a problem with my env vars I don't have much experience with the configuring part of the databases, and I know that Oracle isn't supported on Ubuntu but I like Ubuntu and it's just for learning purposes.

Thank you all for your help.

share|improve this question
    
the link to the tutorial : www.gemsofprogramming.wordpress.com/2013/09/19/installing-oracle-12c-on-ubuntu-1‌​2-04-64-bit-a-hard-journey-but-its-worth-it –  Abdou Abderrahmane Nov 23 '13 at 22:20
    
Welcome to AskUbuntu! You can edit your question to add further information, I have done that for you now. –  LiveWireBT Nov 23 '13 at 23:49
    
I too experience the same problem. –  cognoz Apr 13 at 19:30
    
hey cognoz, if you still have that problem i might be able to help you –  Abdou Abderrahmane Apr 27 at 17:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.