Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

since I heard I could have windows 8 and Ubuntu running at the same computer (using the same HD) i was really exited to test, but unfortunately i'm not being luck doing that :(

My Computer details:

  • Notebook - Dell Inspiron 15R
  • 8Gb RAM
  • 1 TB HD Sata3
  • 30gb SSD
  • Video Card - ATI Radeon HD7700

I was running windows 8.1 without any problem, so here what I did:

  • I create a partition with 100gb (using windows disk utility)
  • I enable legacy boot (disabled uefi and security boot) and changed the dell smart HD control to AHCI
  • Started the ubuntu installation using ubuntu 12.04 iso
  • I did the default procedure, advanced options -> create 4 partitions (/, /home, /boot, swap)
  • When the installation was done I started the live ubuntu 12.04 and I used boot-repair as the tutorial informed to do.

The linux is running perfect but I can't log in windows anymore :(

I can see on grub2 some options, but when I try to load windows 8 i get:

  • Dell recovery screen (the options simple doesn't help me, it says I need to unlock or get permissions of the installation, but the prompt works fine)
  • An screen saying about an unknown issue, some hdx(100,200 blabla bla)
  • I tryied boot repair a lot of times and I don't know how I installed a different boot as well that starts grub
  • Since the prompt works fine I tried the MBR fix procedure and also the boot recovery procedure using disk utility
  • I also tried:
bootrec fixmbr 
bootrec /fixboot
bootrec /scanos
bootrec /rebuildbcd


bcdedit /set {default} device partition=c:
bcdedit /set {default}
osdevice partition=c:
bcdedit /set {bootmgr} device partition=c:

Right now I still can boot windows 8, I know windows 8 is sucks but I really need it since some applications I use only runs on it :(

Any idea in how to fix that?

Pastebin I have with me: http://paste.ubuntu.com/6462192/ http://paste.ubuntu.com/6465662/ ps. I understand it may be a duplicated case, but i expend the last day trying to figured out how to solve but I couldn't, that's why I'm creating and ask with my information - sorry bad english

EDIT:

After the installation I did change the boot mode to UEFI security off (since I didnt choose the boot-repair to create ssh keys with the security boot)

EDIT2:

Error IMAGE: docs.google.com/file/d/0B8mTxJWMEudkaVowUVd2cS15NHpabEwyYnV2NFdmUldKRE5n/edit

EDIT3: imgur.com/WHqXCLa -> Gparted ScreenShot

share|improve this question
    
upload gparted screenshot to imgur.com and paste the link here. –  Avinash Raj Nov 23 '13 at 22:20
    
There you go (: imgur.com/WHqXCLa –  RagazziD Nov 23 '13 at 22:50

2 Answers 2

Luckily, there is a fairly easy solution to this, as this is a common problem (in fact, I've had it myself). Here's what you can do:

  1. Boot up Ubuntu and log in
  2. Press Ctrl+Alt+T to start a Terminal emulator (Terminal)
  3. Type sudo update-grub and press Enter
  4. Let the command finish running, then shut down (it is important you don't restart)
  5. Start up your computer again and....voila! You should now have Windows as an option in your boot menu (GRUB2)

In addition, it's probably a good idea to switch back to UEFI mode, since Windows 8 is configured to run in that, so it may not work otherwise. You may not be able to boot Ubuntu, then, but that can be fixed with a simple boot-repair. In general, you can fix being unable to boot Ubuntu with boot-repair and being unable to boot windows with sudo update-grub.

Good luck with your install!

share|improve this answer
    
Hello Dillmo, I did what you said and I got: Generating grub.cfg ... Found Windows 8 (loader) on /dev/sda7 Adding boot menu entry for EFI firmware configuration done but the problem is, the Windows 8 loader, should be on /dev/sda1 :( –  RagazziD Nov 23 '13 at 21:27
    
Did you try booting to Windows? Do you get an error when you do? It should look something like "Windows Boot UEFI loader" in GRUB2. –  Dillmo Nov 23 '13 at 21:30
    
it does have, but it doesn't load. the error you can see in the image: Checking the partition details, it is pointing to the wrong path, it should be: efi/boot/bootx64.efi or efi/Microsoft/Boot/bootmgr.efi or efi/Microsoft/Boot/bootmgfw.efi. but if I try something different I got ubuntu or Dell Recovery screen (ps. I can access my files normally using Ubuntu) –  RagazziD Nov 23 '13 at 21:40
    
Ops, the URL is: drive.google.com/file/d/… --- PS or I get this error, or I receive dell recovery setup :( –  RagazziD Nov 23 '13 at 21:51

I managed to solve it by my self by restoring the default settings using dell recovery. I had to add the following boot chain on grub to get this working:

/efi/dell/boot/bootx64.efi

After that got my Windows restored to factory image BUT the Linux partitions was untouched! Which means now I can boot on Windows 8 and Ubuntu without any problem.

I guess something happend when I installed ubuntu that crashed the Windows partitions :(

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.