Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently tried to add PPA from this website. I did sudo add-apt-repository ppa:canonical-qt5-edgers/qt5-proper from terminal. I get an error saying

Cannot add PPA: 'ppa:canonical-qt5-edgers/qt5-proper'.
Please check that the PPA name or format is correct.

As suggested in other similar questions, I don't have any problem with internet connection because apt-get install is working as expected. This is not even PPA specific problem, I couldn't add other PPAs as well. This question says that I have to format the entire hard drive to solve this. I definitely cannot do that. Is this bug still unsolved?

I added the PPA line using Software Center. When it updates cache, it comes up with an error saying

W:GPG error: http://ppa.launchpad.net saucy Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F141B5F0C7122F9B, W:Failed to fetch cdrom://Ubuntu 13.04 _Raring Ringtail_ - Release i386 (20130424)/dists/raring/main/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
, W:Failed to fetch cdrom://Ubuntu 13.04 _Raring Ringtail_ - Release i386 (20130424)/dists/raring/restricted/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
, E:Some index files failed to download. They have been ignored, or old ones used instead.

Output of sudo add-apt-repository ppa:canonical-qt5-edgers/qt5-proper

Cannot add PPA: 'ppa:canonical-qt5-edgers/qt5-proper'.
Please check that the PPA name or format is correct.

How to solve this and what is the cause of this problem?

Thanks in advance.

OS: Ubuntu 13.10

AFTER EDIT: Before the edit, the question had PPA of Ubuntu SDK.After posting this, I realised that Ubuntu SDK is in the repositories of Ubuntu 13.10. Just thought, may be that's why I cannot add PPA. I tried next PPA and I came up with the same series of errors.

share|improve this question
3  
Ok, run the following sudo add-apt-repository -m ppa:ubuntu-sdk-team/ppa, copy all the output and edit your question. –  Braiam Nov 23 '13 at 15:14
    
Even with the -m flag, I get the same error as posted in question. "Cannot add PPA....". –  hatter Nov 23 '13 at 15:46
    
The -m flag is not to fix the error... is to debug the error. Copy and paste the output in your question.... –  Braiam Nov 23 '13 at 15:54
    
Here at the manpage -m is not defined. In 14.04 manpage it stands for massive-debug. –  souravc Nov 23 '13 at 16:22
    
@souravc man add-apt-repository indeed shows -m as printing a lot of debug information to the command line. –  hatter Nov 23 '13 at 16:26

2 Answers 2

In addition to configuring proxies, tell sudo to consider the environment with the flag -E

export http_proxy=http://<proxy>:<port>
export https_proxy=http://<proxy>:<port>
sudo -E apt-add-repository ppa:canonical-qt5-edgers/qt5-proper

with username and password:

export https_proxy=<username>:<password>@<proxy>:<port>
share|improve this answer
    
it worked for me thanks. the proxies were configured but sudo was not using them. and the error message was not helping. great answer! –  Bastian Jul 23 at 9:04

try

sudo apt-get install --reinstall ca-certificates

More info at http://www.webupd8.org/2014/03/fix-cannot-add-ppa-please-check-that.html

share|improve this answer
2  
This didn't work –  hatter Mar 4 at 15:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.