Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My java 3d project using netbeans is running fine in my windows environment. But when I run project in Ubuntu 12.04 it shows this exception:

java.lang.UnsatisfiedLinkError: no J3D in java.library.path

This is because I don't know how to install and configure Java 3D in Ubuntu.

I tried

sudo apt-get install libjava3d-java

share|improve this question
    
Welcome to AskUbuntu. You seem to be missing the path to the J3D library. Are you using an IDE or compiling from the command line? –  Luís de Sousa Nov 23 '13 at 9:25
    
Thanks Luís. I'm using Netneans 6.9.1 ide. –  Akshay Raut Nov 25 '13 at 5:37

1 Answer 1

Go to NetBeans and open your project, then right click on the Libraries folder and select Add JAR/Folder.... In the menu that shows up navigate to /usr/share/java, select the j3d jars and click OK. Now try to recompile your project, the missing library errors should be gone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.