Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Ubuntu 12.04 LTS. I'm trying to install glibc-2.18 while ./configure it gives

configure: error: you must configure in a separate build directory

Then I tried to configure in directory bla then it keeps repeating these lines :

checking build system type... (cached) x86_64-unknown-linux-gnu
checking host system type... (cached) x86_64-unknown-linux-gnu
checking for dummy-gcc... (cached) gcc
checking for suffix of object files... (cached) o
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking whether we are using the GNU C++ compiler... (cached) yes
checking whether g++ accepts -g... (cached) yes
checking for dummy-readelf... (cached) readelf
checking for sysdeps preconfigure fragments... x86_64 
configure: running configure fragment for add-on bla
configure: WARNING: you should use --build, --host, --target
configure: WARNING: you should use --build, --host, --target

I'm originally trying to installutorrent-server` which gives :

./utserver: /lib/x86_64-linux-gnu/ version GLIBC_2.16 not found (required by ./utserver)

How to fix this ?

share|improve this question

You should build glibc on another directory instead of glibc source directory.

share|improve this answer

Do something like:

# mkdir  build-tree
# cd  build-tree
# ../configure

This is going to enable you to configure (and build) glibc.

For glibc Ubuntu official build they do the same on debian/rules file.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.