Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Brand new system (custom built w/i5 core and ASUS Z87-PLUS motherboard, 16gb RAM) and drive. Installed 12.04 64 bit via USB onto 3TB SATA drive. Upon completion, reboot and it drops into BIOS. If I install same on an older 1TB drive, it works fine.

Checking the two disks, the 3TB has a 1MB partition at the start, type unknown, whereas the 1TB has the boot partition. Booted from the 1TB and ran disk repair on the 3TB drive. Complete successfully, but trying it by itself, it does not boot (and gparted shows the same 1MB partition).

Here is the report: http://paste.ubuntu.com/6461458/

Any idea as to why Ubuntu is not installing correctly not this disk? Any suggestions to resolve?

If there is another post on this, please let me know - I searched and could not find something similar.

Thanks!

Update: after install, Ubuntu does not boot, but moving drive to another system works. If I install Windows 8 on the 3TB drive, it boots fine. If I then try to install Ubuntu 12.04 for dual boot, it does not see the Windows OS. Any ideas?

share|improve this question
add comment

3 Answers

I think that it is installing correctly, but many BIOS do not support hard drives above the size of 2TB. I would check the website for the motherboard manufacture, and see if it is compatible with large Hard Drives. Then update the BIOS if an update is available. If not, you might have to call customer support for your motherboard manufacturer. They MIGHT be able to help. It is worth a try.

Good Luck, Brooks Rady

share|improve this answer
    
It's odd though, when I look at the disk using gparted, as I don't see the same layout as with the 1TB drive. Good idea to check with the BIOS manufacturer. It's a brand new MB, but I should check for a BIOS updates. –  pcm Nov 23 '13 at 3:30
    
This looks like it may be more likely the cause. I took the 3TB drive and installed in another computer and it booted fine. BIOS is at 1207 and I see on the web site there are 3 newer one. Will try them. –  pcm Nov 23 '13 at 17:00
    
Updated BIOS, but still after install, Ubuntu will not boot. The disk works on another PC. However, I installed Windows 8 on this PC, with the 3TB driver, and it installed and boots fine. I then tried to install Ubuntu, for dual boot, and the installer say there is no OS detected on disk. Totally baffled now. –  pcm Nov 26 '13 at 0:45
add comment

There was a grub bug that they supposedly fixed for / (root) partitions over some very large size like 500GB. You have a massive / partition. I might suggest a 25GB / partition and use the rest of the drive as /home or as data partition(s). Just because we now have these monster multi-TB drives does not mean root should be that size. Not that grub is at 2.5TB and vmlinuz is at .5. Your drive has to jump all over just to boot. Better if all system files are somewhat closer together in a smaller / partition.

share|improve this answer
    
Good point. For now I was anxious to just get the new system to boot and hadn't planned how I wanted to partition it. Will give it a try today. –  pcm Nov 23 '13 at 12:35
    
Tried with 1 GB grub-boot, 16 GB /boot, 16 GB swap, 120 GB /, and 120 GB /home, but see the same result, where it drops back into BIOS and won't boot the disk. –  pcm Nov 23 '13 at 17:01
add comment

Didn't find a direct answer to why Ubuntu didn't boot on the 3TB disk, but did work on a 1TB drive, but I was able to install Windows 8 and then setup for dual boot with Ubuntu 12.04, and I think it gives some hints to the issue.

With the working solution, I had my BIOS set for compatibility mode=auto and preferring UEFI over legacy. When I installed Windows, the BIOS reports the drive as UEFI and I see a EFI partition. When I did Ubuntu, the DVD did the alternate boot (grub like display) that represented a UEFI boot. I had changed secure boot to Other OS, and I added partitions and installed Ubuntu.

I think with the original try I had it booting the Ubuntu installer as a legacy device. I installed Windows, but could not get Ubuntu to see Windows on later installs, I tried to reinstall windows and it complained of a GPT partition that was corrupt. So, I think I was mixing Secure Boot and Not, and UEFI and legacy.

Since my end goal was dual boot, I've got that going now. The source of this question was an early try where I was to just put on Ubuntu, while I was waiting to get Windows.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.