Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried so many things and can't get this to work. I am using the AMD A10-6500k on a ASRock FM2A88X-ITX+ Motherboard. I have installed multiple versions of the AMD Catalyst Propietary driver and no matter what I do I cannot get Ubuntu to recognize my sound device. Here is some relevant info.

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 0: ALC1150 Analog [ALC1150 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 1: ALC1150 Digital [ALC1150 Digital]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

lsmod | grep '^snd'

snd_hda_codec_realtek    56599  1 
snd_hda_intel          48210  5 
snd_hda_codec         188852  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              13602  1 snd_hda_codec
snd_pcm               102033  3 snd_hda_codec,snd_hda_intel
snd_page_alloc         18710  2 snd_pcm,snd_hda_intel
snd_seq_midi           13324  0 
snd_seq_midi_event     14899  1 snd_seq_midi
snd_rawmidi            30095  1 snd_seq_midi
snd_seq                61560  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         14497  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              29433  2 snd_pcm,snd_seq
snd                    69141  19 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_seq_midi

lspci -vk | egrep -iA13 "audio"

00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)
    Subsystem: ASRock Incorporation Device 1150
    Flags: bus master, slow devsel, latency 32, IRQ 16
    Memory at ff740000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 2
    Kernel driver in use: snd_hda_intel

00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 11)
    Subsystem: ASRock Incorporation Device 780e
    Flags: bus master, 66MHz, medium devsel, latency 0

00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] FCH PCI Bridge (rev 40) (prog-if 01 [Subtractive decode])
    Flags: bus master, 66MHz, medium devsel, latency 64
    Bus: primary=00, secondary=02, subordinate=02, sec-latency=64

Any help would be greatly appreciated. If you need any more info please let me know. Thank You.

share|improve this question
    
Close voters: This question has a good answer, there is no need to close it. –  Seth Nov 27 '13 at 3:51

1 Answer 1

OK so answering my own question here. I should have looked at this before I tried all the things I tried. On the ASRock FM2A88X-ITX+ the HDMI audio is disabled by default. That's it.

share|improve this answer
    
You should ask for your accounts to be merged in the contact us link below. –  Braiam Nov 24 '13 at 0:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.