Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As a summary: I wanted to install the latest SCilab, which is not available in the Software centre. I downloaded the tar.gz file from the website. I then followed the instructions from response 7 here How to install a .tar.gz (or .tar.bz2) file?. This didn't work for me. So I removed the file (I think), and extracted the file a different way and ran the program from there.

Okay, so I downloaded Scilab from their website as a tar.gz file.

I then copied the file to /opt:

 sudo cp [download name].tar.gz /opt/ 

I then extraced the file and deleted the tar.gz file:

 sudo tar -xvf [download name].tar.gz
sudo rm -rf [download name].tar.gz 

I found the folder. It was called Scilab-5.4.1. I think the next step changes the "access" settings, and so I changed it as follows:

 sudo chmod 770 Scilab-5.4.1/ 

So this is owner and group permission to read, write and execute.

I then tried the symbolic link thing:

 sudo ln -s /opt/Scilab-5.4.1/ /usr/bin/scilab 

After this, I tried different ways to run the programme from the terminal, but to no avail. I then looked for the Scilab folder, which I found in opt. I tried to delete the folder "Windows-style" (send to recycling bin) but it wouldn't let me. I also tried purge from the terminal but it couldn't find the programme. I then used:

 sudo rm -r /opt/Scilab-5.4.1 

The folder disappeared. After this, I downloaded the file again, and transferred it to opt in the process:

 sudo tar xzvf [download name].tar.gz -C /opt/ 

I then went to the folder (in terminal):

 cd /opt/scilab-5.4.1 

And opened Scilab:

 ./bin/scilab 

This seems to work. However, there is a Scilab programme logo in the launcher (Unity), but it disappears on closing the programme and there is no logo in the recently used programmes section in the dash.

I want to know that was there an error in my installing process done in the previous unsuccessful install, since I can't find the Scilab logo anywhere ?

Why first method didn't work but the second, simpler method, seemed to work okay (I can at least open the programme) ?

(The final peculiar thing is my "history" in the terminal: using the up-arrow to navigate to previous commands, the history suggests I didn't use rm -r, even though I am almost certain I did.)

share|improve this question
    
If the steps of the first installation try are literal, you forgot to cd /opt before decompressing the file --- so Scilab ended in your current directory. The symlink ins wrong, too. Braiam answer should take care of the rest. –  Rmano Nov 22 '13 at 21:22
    
Thanks, Rmano. I omitted some of the "less important" steps such as changing the directory to keep it more succinct. I am not sure I removed the programme correctly. Let us say I wanted to run Scilab. I have two Scilab locations: one in /opt/Scilab-5.4.1 and one in /home/jayjay/scilab so I can use cd to go to both locations and run ./bin/scilab. Is this duplication a normal event in Ubuntu? (I'm new to the whole Linux thing) Many thanks –  Jayjay Nov 23 '13 at 0:00
    
No, this is not normal. It is possible that Scilab creates a directory in your home to save data and settings, but it's not normal to have two copies of it. –  Rmano Nov 23 '13 at 0:06
    
Thanks, Rmano. I tried to remove as much of Scilab-5.4.1 as I could using get-apt remove or purge and using rm -r. There are still files and hidden folders scattered around in directories I have never heard of. But I tried to remove as much as possible. I then downloaded the tar file again and extracted to /opt/ I am assuming any files not deleted that are necessary are simply replaced with the new extraction, and those that are present from previous wayward Scilab downloads will be ignored: they won't affect the most recent extraction, will they? –  Jayjay Nov 23 '13 at 16:28
    
Probably you're ok. –  Rmano Nov 23 '13 at 17:25

1 Answer 1

up vote 2 down vote accepted

To make Scilab present in the path, you must modify your symbolic link creation to:

sudo ln -s /opt/Scilab-5.4.1/bin/scilab /usr/bin/scilab

That way you can type scilab in the shell and open it. For creating the icon:

gedit ~/.local/share/applications/scilab.desktop

Now add the following content:

[Desktop Entry]
Name=Scilab
Comment=Scilab-5.4.1
Exec=/usr/bin/scilab
Terminal=false
Type=Application
StartupNotify=true

Now you can pin it to the dash or just searching for "Scilab".

share|improve this answer
    
@Rmano. Thanks to both of you for the help. I followed your advice: I created a symbolic link, which was successful. For creating the icon, the path you gave didn't work, I found where the *.desktop files all seem to be kept; I then copied the scilab.desktop file from the /opt/ folder to this other folder and changed StartupNotify and Exec to match your information. It seems to work; however, how do I change the icon from a question mark to the Scilab logo? Many thanks. –  Jayjay Nov 23 '13 at 16:19
    
You must add/edit the Icon= stanza in the desktop file and point fill it with the full path, example: Icon=/usr/where/all/icons/are/scilab.ico or something. –  Braiam Nov 23 '13 at 16:31
    
Thanks Braiam. I was just doing some research and found the logo in the icons section of /opt/Scilab and used gedit to change the icon path for the scilab.desktop file in /usr/... I used the 48x48. This is similar to what you recommend except I can;t find a "logo repository" where all logos are kept. Instead, I used the seemingly very specific 48x48 logo (since this matches the launcher icon size). –  Jayjay Nov 23 '13 at 16:44
    
@Jayjay is not a logo repository, but I guessed the Scilab would have more icons (16x16, 48x48, 128x128, etc) so I was just giving you a example of the path. BTW, if my answer solved your question or there is some inacurancies feel free to edit/accept it. –  Braiam Nov 23 '13 at 17:03
    
Thanks Braiam. I thought you meant a repository in a similar fashion to the *.desktop repository I found in /usr/... If the 48x48 logo works fine - which it seems to - I'll leave it at that. Many thanks for the help. –  Jayjay Nov 23 '13 at 17:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.