Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I dual booted my computer which originally had Windows 7 installed on it, with Backtrack 5 R3. I went through the install process perfectly and BT was working very well.

I then restarted my system and booted up into Windows. I went into disk management, because I was curious about what partition BT was installed on, and by mistake I deleted the partition that it was installed on.

I thought there was nothing on this partition and was really stupid not to check how much space had been used on the drive. Anyways, I restarted my computer and came up to the screen that says:

"error: unknown file system Grub rescue>!!!!!!

This is EASY to fix, I had it once before with Linux Mint. I just repaired the boot loader with my Windows 7 Recovery Disk. However, this time it is not as simple. I cant boot into ANY CDs/DVDs, including my Windows 7 disk and backtrack, even though my first boot device is set to Internal CD ROM.

The problem is that when I boot up my computer, I cannot access my BIOS. No onscreen keys r shown (the usual F2 on my LG laptop). I have tried all key combinations incase it had switched my BIOS key, which is very unlikely, but it was worth a shot. It just takes me straight to the GRUB rescue prompt where I can virtually do nothing. I,ve tried LS at the rescue and tried to boot up into one of the hard disks, help commands and any other obvious commands that I thought might work, but nothing!

I cant remember off-hand all the model numbers, but my laptop is an LG , as I mentioned above and have a Toshiba HDD.

Anything else you need to know ?

How can I fix this ?

share|improve this question

1 Answer 1

Sometimes a laptop can boot a little too quickly to let you into the BIOS. As you say you know the typical key for your laptop, give this a try:

  1. Turn off your laptop.
  2. Disconnect the mains power connection to your laptop.
  3. Remove the battery (if possible) from your laptop.
  4. Give it a minute, then plug the battery back in.
  5. Switch on the laptop and immediately keep pressing F2 to see if it lets you in.

Thanks

share|improve this answer
    
Thanks for the reply. I died it with great hopes that it would work, but still the same old problem! 1 thing I forgot to mention in my question is that ive tried taking out my RAM and HDD, removing battery, power cable etc –  Aaron Nov 22 '13 at 20:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.