Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Hi I've just installed Ubuntu on my second HDD, everything went perfect but when I boot up the pc from that HDD and then select Ubuntu on grub's menu, the login screen's music sounds but the screen is black, even the monitor goes to power save mode.

I have been trying to use boot-repair and all other things but it always turns up the same way: black screen at login

I also tried to switch between non-graphical consoles but nothing changes, still black screen.

Thanks in advance.

share|improve this question

marked as duplicate by bodhi.zazen, user68186, guntbert, karel, Eric Carvalho Nov 24 '13 at 4:08

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

I have tried that post's solutions. I managed to enter to a termnial with nomodeset setting in grub, I downloaded and managed to see the login screen, from there If I try to go to a terminal it will show a black screen. If I log in, I will have a message telling that there was a problem with the system and a black screen. I can't go to a terminal neither, black screen as well again.

I have tried to reinstall ubuntu, but always same thing happens. What am I doing wrong?

I am trying to install ubuntu on a second hard drive, so If I select that hard drive in the bios to boot from, it shows the grub screen and if i don't boot from that hard drive, then it will boot from the default hard drive which has windows on it.

When I install ubuntu, I select the hard drive, make a ext4 partition in it (lets say the hard drive is sdb and the partition is sdb3, then i choose to install boot in sdb, but when i boot for the frist time grub rescue screen will show. Then start with a live cd, use boot-repair and then, after that, i can boot to grub from the second hard drive. After that all, the problem begins.

What am I doing wrong?

My relevant system specs:

motherboard: Gigabyte GA-Z87X-D3H processor: Intel Core i7-4770K gpu: Sapphire R9 280X Dual-X

Ubuntu 13.10 x64

I have been trying solutions, reinstalling, etc for hours and I can't manage to get this working, hope you guys know how to do it :S

Thank you again

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.