Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I read a couple of other questions on this topic and they both pointed to the Grub2 community documentation and installing grub configs from an install disk. I had some trouble with the documentation, so here's where I am. This may be complete PEBKAC.

I have two guests sitting on an Ubuntu 10.04 server virtualized under KVM, both were initially running 10.04. I used "do-release-upgrade" to update to 10.10 without a hitch on both boxes, rebooted, and then ran "do-release-upgrade" to update to 11.04 on both boxes. In my haste, I ignored the errors about missing grub configurations. When I restarted the guests, naturally I'm presented with a grub prompt. Issuing "boot" yields "error: no loaded kernel".

Here's ls output for the root partition:

grub prompt ls output

When following the manual boot guide, I can't get the options straight either using "SS928-root" or "hda0,1" as the root filesystem. Most everything gives the "file not found" error.

Issuing "ls" on both of those filesystems show several options for vmlinuz and initrd.img. These guests are using LVM if that helps any.

EDIT

I've gotten a little bit further. The following command sequence:

semi-successful boot

Yields the following screen (after scrolling through quite a bit of text):

BusyBox Shell

share|improve this question
add comment

2 Answers 2

up vote 4 down vote accepted

After looking at jdehaan's post, I checked out a machine with a similiar configuration. Going off another box's grub.cfg, I used the following commands to get this thing to boot:

recordfail
insmod ext2
set root='(hd0,1)'
linux /vmlinuz-2.6.32-server root=/dev/mapper/SS928-root ro quiet
initrd /initrd.img-2.6.32.30-server
boot

I suppose the next step is figuring out how to replace the grub.cfg on this machine now.

share|improve this answer
add comment

I had the same issue and could solve the problem by specifying

linux /boot/vmlinuz.... root=/dev/sda1

So /dev/sda1 (or what will match on your system) instead of the SS... The rest of your posts was kept alike during my tries.

share|improve this answer
    
I suppose that, in theory, because this thing is running LVM that should be /dev/mapper/SS928-root. That's definitely not working in this instance. –  cmhobbs May 2 '11 at 20:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.