Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Juju with MAAS on a 12.04 in order to deploy OpenStack Havana.

In order to do this I have successfully deployed the recommended charms with the openstack-origin set to "cloud:precise-havana" while forcing some of them to be deployed on the same node :

On the "cloud-controller" node :

  • openstack-dashboard
  • cinder
  • glance
  • keystone
  • nova-cloud-controller (with network-manager set to "Neutron")
  • quantum-gateway
  • mysql
  • rabbitmq-server

On a "compute" node :

  • nova-compute

Relations are established following the installation guide.

My issue now : the Horizon web interface is crashing right after logging in with this exception value "Connection to neutron failed: Maximum attempts reached".

Actually, even if the keystone CLI client is telling me that there is an endpoint for Quantum/Neutron (on port 9696) it seems there is no quantum/neutron server listening on 9696 to manage this API : "netstat -na | grep LISTEN" is not showing any 9696 open port on my "cloud-controller" node. CLI client is not able to connect to Neutron too.

Removing the "quantum-gateway" from this node and deploying it on another one is not helping, in fact I saw that the endpoint for the quantum API in keystone hasn't changed to the new node IP : the endpoint is still pointing to the "cloud-controller" node.

Finally, I see no "quantum-server" or "neutron-server" package installed neither on my "cloud-controller" node or on the node I have moved the "quantum-gateway" charm.

How can I get my Quantum/Neutron service working ?

share|improve this question
    
which services did you force onto the same node? –  jamespage Nov 22 '13 at 11:24
    
Basically I have deployed mostly all openstack related cvharms in the same node except nova-compute. Then I used another node to deploy the "quantum-gateway" charm to test this. –  Julien Leloup Nov 22 '13 at 12:35
    
that should be OK –  jamespage Nov 22 '13 at 12:51

1 Answer 1

up vote 2 down vote accepted

The Neutron API server resides on the Nova Cloud Controller (this will probably change for 14.04 and bit split out to be its own charm).

I'd check to ensure that neutron-server is installed on the nova-cloud-controller node:

apt-cache policy neutron-server

Question: when did you configure the network-manager for the nova-cloud-controller service?

share|improve this answer
    
I believed that "neutron-server" wasn't installed since "dpkg --get-selections | grep neutron-" wasn't telling me so, but using "apt-cache policy neutron-server" is showing this : neutron-server: Installed: (none) Candidate: 1:2013.2-0ubuntu1~cloud0 Version table: 1:2013.2-0ubuntu1~cloud0 0 500 ubuntu-cloud.archive.canonical.com/ubuntu precise-updates/havana/main amd64 Packages –  Julien Leloup Nov 22 '13 at 12:37
    
To answer your question, I configured the "network-manager" parameter using a local yaml file and providing it to juju when deploying this charm. –  Julien Leloup Nov 22 '13 at 12:41
    
that's how it should be done (its a install time config option) - could you check in /var/log/juju on the nova-cloud-controller node to see if the Neutron configuration was picked up in the install hook. –  jamespage Nov 22 '13 at 12:54
    
I'm not really familiar with the logs produced by Juju but I don't see anyhints of a Neutron configuration during the install hook. I will destroy and redeploy "nova-controller-cloud" since I have a doubt for the "network-manager" parameter : I'm not sure if I put "Neutron" or "Quantum" during the installation, and I changed it 2 or 3 times during the troubleshooting of this issue (only for reconfiguring, not redeploying). –  Julien Leloup Nov 22 '13 at 13:13
    
Ok, so I was using "Quantum" in my config.yaml file during deployment and was changing to "Neutron" after. When redeploying with "Neutron" for "network-manager" Juju got the "neutron-server" package and installed it properly. One more time the Chair-Keaboard Interface was faulty :). Thanks for your answers James. –  Julien Leloup Nov 22 '13 at 13:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.