Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running 11.04 on a 2011 13" mackbook pro (intel hd 3000 gpu).

Previously everything had been fine, but today when I plug in an external monitor (17" Acer being plugged in via a mini display port to VGA adapter) the laptop immediately recognizes the monitor, but the screen turns black. It seems that everything is still responsive. I can see the cursor and I can see it change as it moves over things like text boxes or the edges of open windows. But even after unplugging the monitor, I can't get anything but a black screen until I restart gdm.

Yesterday I was using the laptop with a 22" Asus monitor using a mini display port to DVI adapter and everything was fine. This same monitor was also working fine last week when I was running OS X, and on an older HP laptop without an adapter (straight to VGA).

How can I fix this?

share|improve this question
Found any solution? Happening to me too in an Asus u35jc-a1, external monitor Samsung T220. At first I thought it was related to Unity, but it's happening in Gnome 2 as well. – Seb May 1 '11 at 21:45
up vote 4 down vote accepted

Just found the official bug page, with possible workarounds such as installing other kernel versions:

For the time being, it seems we have to wait or play with other kernels...

EDIT: I've just installed and tried kernel linux-headers-2.6.39-020639rc4 and works like a charm - at least in this regard. I hope it's as stable as the previous one as well!

share|improve this answer
thanks for that. I guess the waiting begins. – gregghz May 2 '11 at 0:16
where did you get that kernel?? – gregghz May 2 '11 at 17:20
ok, i found that kernel. I tried it and it works ... better .... it doesn't cause my main screen to go blank. But on the external monitor, it's completely black except for the unity panel thing (not sure what to call it) at the top and the cursor. (this kernel: – gregghz May 2 '11 at 17:37
the kernel here: exhibits the same behavior as the one I previously mentioned. – gregghz May 2 '11 at 17:53
BTW, everything is working fine now on a 3.0 kernel. I also had it working on a 2.39 kernel. – gregghz Oct 21 '11 at 16:42

Installing a new 2.6.39 kernel solved a problem in my case. Here are step by step instructions for less experienced users:

share|improve this answer
as mentioned in the comments on Seb's answer, no dice. The laptop monitor works fine with the newer kernels, but the external one is still a black screen. – gregghz May 3 '11 at 15:44
Did you try the one from here: ? It's 2.6.39-rc5 not 2.6.39-rc4 so maybe it will work better... and it actually did work for me. – blazej May 4 '11 at 1:22

I am running Ubuntu 11.04 with both a Nvidia and an integrated Intel AGP in my laptop.

I am using an external monitor connected through a mini DisplayPort wired to the Intel card. It has been working since I installed Ubuntu 11.04 a month a go, today the external monitor stopped responding:

  • The external monitor reports no sync
  • System > Preferences > Monitors reports the external monitor as attached and operational.
  • Print Screen includes the image of the external monitor
  • The laptop primary monitor works as expected.

After double checking the cables, connections and the external monitor I booted back in the previous Kernel (I suppose yesterday I got an kernel update) and the external monitor came back to life. I did the test forth an back a couple times and the behavior was consistent.

The offending Kernel is 2.6.38-11-generic.

Last known good Kernel is 2.6.38-10-generic.

So far I am sticking to the previous Kernel while using an external monitor.

Following are my graphics device info:

anibal@collar-de-bolas:~ $ lspci | grep -i VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: nVidia Corporation Device 0df4 (rev a1)
anibal@collar-de-bolas:~ $ sudo lshw -C video
[sudo] password for anibal: 
       description: VGA compatible controller
       product: nVidia Corporation
       vendor: nVidia Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:16 memory:f0000000-f0ffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:3000(size=128) memory:f1000000-f107ffff
       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:54 memory:f1400000-f17fffff memory:e0000000-efffffff ioport:4000(size=64)
share|improve this answer
Just filled a Kernel bug for this: please go an check it if it aplies to you. – Aníbal Rojas Aug 31 '11 at 15:41

As a workaround to be able to continue work, look here


You need to go to a tty shell (with no ui) by using, for example, ctrl+alt+F2. In the tty shell, you need to login and find any compiz process, using the command

ps -ef | grep compix

Then, kill all the compiz processes:

kill -9 <processes ids separated using space>

Then run unity to initialize the UI:


Give it a moment to load and go back to the 'UI shell', using ctrl+alt+F8, to see the UI being initialized.

share|improve this answer

I had this problem with a DVI monitor plugged into a dock, using Ubuntu 11.10. I solved it by deleting the file ~/.config/monitors.xml

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.