Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This has happened to me twice now. The first time I had to reinstall Xubuntu, and now I would like to avoid that and discover the root of the problem.

I have two machines, A and B. Both machines have the same set up hardware wise (same motherboard, GPUs and OS). After unplugging a USB cable in machine A, machine B froze and was inactive. No idea how that is connected. Happened twice.

/var/log/syslog had no information, but I've noticed the PCI-e x16 slot isn't being recognized now.

lspci -v shows:

- Machine A:

    00:00.0 Host bridge: Advanced Micro Devices [AMD] nee ATI RD890 PCI to PCI bridge (external gfx0 port B) (rev 02)
        Subsystem: ASRock Incorporation Device 5a14
        Flags: fast devsel
        Capabilities: <access denied>

    00:02.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RD890 PCI to PCI bridge (PCI express gpp port B) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        I/O behind bridge: 0000e000-0000efff
        Memory behind bridge: fea00000-feafffff
        Prefetchable memory behind bridge: 00000000c0000000-00000000cfffffff
        Capabilities: <access denied>
        Kernel driver in use: pcieport
        Kernel modules: shpchp

    00:03.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RD890 PCI to PCI bridge (PCI express gpp port C) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
        I/O behind bridge: 0000d000-0000dfff
        Memory behind bridge: fe900000-fe9fffff
        Prefetchable memory behind bridge: 00000000b0000000-00000000bfffffff
        Capabilities: <access denied>
        Kernel driver in use: pcieport
        Kernel modules: shpchp

- Machine B:

    00:00.0 Host bridge: Advanced Micro Devices [AMD] nee ATI RD890 PCI to PCI bridge (external gfx0 port B) (rev 02)
        Subsystem: ASRock Incorporation Device 5a14
        Flags: fast devsel
        Capabilities: <access denied>

    00:03.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RD890 PCI to PCI bridge (PCI express gpp port C) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        I/O behind bridge: 0000e000-0000efff
        Memory behind bridge: fea00000-feafffff
        Prefetchable memory behind bridge: 00000000c0000000-00000000cfffffff
        Capabilities: <access denied>
        Kernel driver in use: pcieport
        Kernel modules: shpchp

Notice the lack of 00:02.0 in machine B, but the Host bridge is active for port B (just not a gpp as well.). I've confirmed that the dir /sys/devices/pci0000:00/0000:00:02.0 is missing in machine B but exist on machine A.

I've been at this for 4 hours now.

What can I do for save myself ?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.