Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem with wifi on my laptop Lenovo Ideapad Y580 (bought with pre-installed Windows 7 Home Premium 64bit). After uninstall Win7 and install Ubuntu 13.10 64bit (where normal wired internet is working) wifi doesn't work!

Wireless is disabled by hardware switch.

rfkill list all

martin@martin-Y580:~$ rfkill list all
0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

I checked the BIOS, and the wireless card is enabled there.

Fn + F5 didn't work, and my computer doesn't have a physical switch on the outside, which is why I asked here.

rfkill unblock all change only soft blocks, and sudo ifconfig wlan0 up shows me this: SIOCSIFFLAGS: Operation not possible due to RF-kill.

Some specifications:

lshw -class network

martin@martin-Y580:~$ lshw -class network
*-network DISABLED
       description: Wireless interface
       product: Centrino Wireless-N 2200
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: c4
       serial: 9c:4e:36:4c:9f:7c
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.11.0-13-generic firmware=18.168.6.1 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:43 memory:d3500000-d3501fff

lspci

martin@martin-Y580:~$ lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 IDE interface: Intel Corporation 7 Series Chipset Family 4-port SATA Controller [IDE mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
00:1f.5 IDE interface: Intel Corporation 7 Series Chipset Family 2-port SATA Controller [IDE mode] (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GTX 660M] (rev a1)
02:00.0 Ethernet controller: Qualcomm Atheros AR8161 Gigabit Ethernet (rev 08)
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 2200 (rev c4)
04:00.0 System peripheral: JMicron Technology Corp. SD/MMC Host Controller (rev 30)
04:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller (rev 30)
04:00.3 System peripheral: JMicron Technology Corp. MS Host Controller (rev 30)
04:00.4 System peripheral: JMicron Technology Corp. xD Host Controller (rev 30)

uname -a

martin@martin-Y580:~$ uname -a
Linux martin-Y580 3.11.0-13-generic #20-Ubuntu SMP Wed Oct 23 07:38:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux`

How can I solve this issue ?

share|improve this question
    
I'm having a similar problem in 13.10. lshw says my ethernet bridge is disabled. Is this related to you'r problem? –  Stanton.Sculpture Nov 23 '13 at 18:48
    
I think so. What are we gonna do? –  user218158 Nov 24 '13 at 21:54
    
Update. Ok so I got my system working again. I checked the network icon in the notification bar and I clicked "enable networking" which I never had to do before and I clicked "auto ethernet" which was also never an option before, at least that I could notice. Anyway, now it is working and I don't know how networking got disabled or what, but thats what I had to do. I don't know if this answers your question, but give it a try it worked for me. –  Stanton.Sculpture Nov 28 '13 at 18:53

6 Answers 6

You should click "Suspend", and then wake computer.
It works for me. (Asus x75vcp, Ubuntu 14.04 LTS x64)

share|improve this answer
    
This worked for me! Asus Ubuntu 14.04 LTS AMD64. –  Rao Jul 23 at 14:36

The solutions above did not work for me (HP 6910p). I ended up finding a YouTube video where a guy just set BIOS back to defaults, saved and then booted normally. I didn't believe something so simple would work but I was desperate. Anyway, it works! I wonder why this bug hasn't been fixed yet... There are a lot of articles dedicated to trying to solve it!

share|improve this answer

For my Lenovo Thinkpad's this worked.

Type this in a terminal(that can be opened with Ctrl+Alt+t):-

sudo nano /etc/modprobe.d/blacklist.conf

and add this at the end of that file:-

blacklist ideapad_laptop

and then save the file.

Now reboot.

share|improve this answer

This worked for my Lenovo Miix 2 11'' i5:

You can temporarily disable ideapad_laptop by

sudo modprobe -r ideapad_laptop

If your WiFi works now you can follow krishcdbry's solution

share|improve this answer

Well, I had installed ubuntu 13.10 on a new machine but messed my network setting up.

  1. I installed gksu

  2. Runned: sudo gksu gedit

    in gedit open your network interfaces file found in etc-network-interfaces

  3. Edit the file with:

    • # This file describes the network interfaces available on your system
    • # and how to activate them. For more information, see interfaces(5).
    • # The loopback network interface
    • auto lo
    • iface lo inet loopback
    • # This is a list of hotpluggable network interfaces.
    • # They will be activated automatically by the hotplug subsystem.
    • # auto eth1
    • # iface eth1 inet dhcp

    then just save it.

  4. Just to make sure everything is ok a. please check your dhcpd.conf file found in etc-dhcp-dhcpd.conf to make sure

    option domain-name "example.org";

    option domain-name-server ns1.example.org, ns2.example.org;

    default-lease-time 600;

    max-lease-time 7200;

    do not have # before them.

  5. now retart your system and I hope it works just like mine did

share|improve this answer

Some laptops have Fn key (red color), and wifi can be disabled or enabled using said Fn key in combination with Function key (usually F5).

Try doing that.

share|improve this answer

protected by Community Jul 21 at 20:06

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.